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Introduction

Excel worksheets are used in many walks of life: business, education, home 
finances, and even hobbies (such as keeping track of your baseball-card  
collection). In my house, we use Excel for a lot, from our taxes (boring!) to 

our ever-growing recipe collection (yummy!). Often, I use Excel in place of a  
calculator. After all, Excel is like a calculator on steroids!

In the workplace, Excel is one of the most commonly used analysis and reporting 
tools. Financial statements, sales reports, inventory, project scheduling, customer 
activity  — so much of this stuff is kept in Excel. The program’s capability to 
manipulate and give feedback about the data makes it attractive. Excel’s flexibility 
in storing and presenting data is like magic.

About This Book
This book is about the number-crunching side of Excel. Formulas are the keystone 
to analyzing data — that is, digging out nuggets of important information. What 
is the average sale? How many times did we do better than average? How many 
days are left on the project? How much progress have we made? These sorts 
of things.

Formulas calculate answers, straight and to the point. But that’s not all. Excel has 
dozens of built-in functions that calculate everything from a simple average to a 
useful analysis of your investments to complex inferential statistics. But you don’t 
have to know it all or use it all; just use the parts that are relevant to your work.

This book discusses more than 150 of these functions. But rather than just show 
their syntax and list them alphabetically, I assemble them by category and provide 
real-world examples of how to use them alone, and in formulas, along with step- 
by-step instructions and illustrations of the results.

Within this book, you may note that some web addresses break across two lines of 
text. If you’re reading this book in print and want to visit one of these web pages, 
simply key in the web address exactly as it’s noted in the text, pretending as 
though the line break doesn’t exist. If you’re reading this as an e-book, you’ve got 
it easy — just click the web address to be taken directly to the web page.
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Foolish Assumptions
I assume that you have a PC with Excel loaded. That’s a no-brainer! Nearly all the 
material is relevant for use with earlier versions of Excel as well. I also assume 
that you know how to navigate with a keyboard and mouse. Last, I assume that 
you have used Excel before, even just once. I do discuss basics in Chapter 1 but not 
all of them. If you really need to start from scratch, I suggest that you read the 
excellent Excel All-in-One For Dummies, by Paul McFedries and Greg Harvey (Wiley).

Other than that, this book is written for the Microsoft 365 version of Excel, but 
just between you and me, it works fine with older versions of Excel. There can be 
a function or two that isn’t in an older version or works slightly differently. But 
Microsoft has done an excellent job of maintaining compatibility between ver-
sions of Excel, so when it comes to formulas and functions, you can be confident 
that what works in one version works in another.

Icons Used in This Book
This book uses icons in the margins to grab your attention. Here’s a guide to what 
the icons mean:

The Tip icon highlights information that’ll make your life easier — at least when 
it comes to Excel.

The Remember icon marks some basic concept that you’ll want to keep tucked 
away somewhere in your brain.

As it implies, the Warning icon is used for serious stuff. This icon tells you to be 
careful  — usually because you can accidentally erase your data or some such  
horrible event.

Once in a while, some tidbit is interesting to the tech-head types but not to  
anyone else. I mark these paragraphs with the Technical Stuff icon. You can  
read these items or ignore them as you see fit.



Introduction      3

Beyond the Book
In addition to the material in the print or e-book you’re reading right now, this 
product also comes with some access-anywhere goodies on the web. Be sure to 
check out the free online Cheat Sheet to find the Excel order of operations, Excel 
cell references worth remembering, common Excel error messages, and more. To 
get the Cheat Sheet, simply go to www.dummies.com and type Excel Formulas & 
Functions For Dummies Cheat Sheet in the Search box.

Where to Go from Here
Roll up your sleeves, take a deep breath, and then forget all that preparing-for-a- 
hard-task stuff. Using Excel is easy. You can hardly make a mistake without 
Excel’s catching it. If you need to brush up on the basics, go to Chapter 1. That 
chapter is also the best place to get your first taste of formulas and functions. 
After that, it’s up to you. The book is organized more by area of focus than  
anything else. If finance is what you do, go to Part 2. If working with dates is what 
you do, go to Part 4. Seek, and you will find.

http://www.dummies.com/
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IN THIS PART . . .

Get to know formula and function fundamentals.

Discover the different ways to enter functions.

Understand array-based formulas and functions.

Find out about formula errors and how to fix them.
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Chapter 1
Tapping into 
Formula and Function 
Fundamentals

Excel is to computer programs what a Ferrari is to cars: sleek on the outside 
and a lot of power under the hood. Excel is also like a truck. It can handle all 
your data — lots of it. In fact, in Excel, a single worksheet has 17,179,869,184 

places to hold data. Yes, that’s what I said — more than 17 billion data placehold-
ers. And that’s on just one worksheet!

The number of available rows and columns may be fewer depending on how much 
memory your computer has.

Excel is used in all types of businesses. And you know how that’s possible? By 
being able to store and work with any kind of data. It doesn’t matter whether 
you’re in finance or sales, whether you run an online e-commerce store or organ
ize wilderness trips, or whether you’re charting party RSVPs or tracking the scores 
of your favorite sports teams — Excel can handle all of it. Its number-crunching 
ability is just awesome! And so easy to use!

IN THIS CHAPTER

»» Getting the skinny on the Excel basics

»» Writing formulas

»» Working with functions in formulas
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Just putting a bunch of information on worksheets doesn’t crunch the data or give 
you sums, results, or analyses. If you just want to store your data somewhere, you 
can use Excel or get a database program instead. In this book, I show you how to 
build formulas and how to use the dozens of built-in functions that Excel  
provides. That’s where the real power of Excel is — making sense of your data.

Don’t fret that this is a challenge and that you may make mistakes. I did when I 
was ramping up. Besides, Excel is very forgiving. Excel usually tells you when you 
made a mistake, and sometimes it even helps you correct it. How many programs 
do that? But first, the basics. This first chapter gives you the springboard you need 
to use the rest of the book. I wish that books like this were around when I was 
introduced to computers. I had to stumble through a lot of this.

Working with Excel Fundamentals
Before you can write any formulas or crunch any numbers, you have to know 
where the data goes and how to find it again. I wouldn’t want your data to get lost! 
Knowing how worksheets store your data and present it is critical to your analy-
sis efforts.

Understanding workbooks and worksheets
In Excel, a workbook is the same as a file. Excel opens and closes workbooks, just 
as a word processor program opens and closes documents. When you start up 
Excel, you are presented with a selection of templates to use, the first one being 
the standard blank workbook. Also there is a selection of recent files to select 
from. After you open a new or already created workbook, click the File tab to view 
basic functions such as opening, saving, printing, and closing your Excel files (not 
to mention a number of other nifty functions to boot!). Figure 1-1 shows the con-
tents presented on the Info tab.

The default Excel file extension is .xlsx. However, you may see files with the 
older .xls extension; these older files work fine in the latest version of Excel. You 
may also see Excel files with the .xslm extension; those are fine to use, too.

Start Excel and double-click the Blank Workbook icon to create a new blank work-
book. When you have more than one workbook open, you pick the one you want to 
work on by clicking it on the Windows Taskbar.
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A worksheet is where your data actually goes. A workbook contains at least one 
worksheet. If you didn’t have at least one, where would you put the data?  
Figure 1-2 shows an open workbook that has two sheets, aptly named Sheet1 and 
Sheet2. To the right of these worksheet tabs is the New Sheet button (looks like a 
plus sign), used to add worksheets to the workbook.

At any given moment, one worksheet is always on top. In Figure 1-2, Sheet1 is on 
top. Another way of saying this is that Sheet1 is the active worksheet. There is 
always one and only one active worksheet. To make another worksheet active, just 
click its tab.

FIGURE 1-1: 
The Info tab 

shows details 
about your 

Excel file.

FIGURE 1-2: 
Looking at a 

workbook and 
worksheets.
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Worksheet, spreadsheet, and just plain old sheet are used interchangeably to mean 
the worksheet.

What’s really cool is that you can change the name of the worksheets. Names like 
Sheet1 and Sheet2 are just not exciting. How about Baseball Card Collection or Last 
Year’s Taxes? Well, actually, Last Year’s Taxes isn’t too exciting, either.

The point is, you can give your worksheets meaningful names. You have two ways 
to do this:

»» Double-click the worksheet tab and then type a new name.

»» Right-click the worksheet tab, select Rename from the menu, and then type 
a new name.

Press Enter to complete the name change.

Figure 1-3 shows one worksheet name already changed and another about to be 
changed by right-clicking its tab.

You can try changing a worksheet name on your own. Do it the easy way:

1.	 Double-click a worksheet’s tab.

2.	 Type a new name and press Enter.

The name cannot exceed 31 characters.

You can change the color of worksheet tabs. Right-click the tab and select Tab 
Color from the menu. Color coding tabs provides a great way to organize your work.

FIGURE 1-3: 
Changing the 

name of a 
worksheet.
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To insert a new worksheet into a workbook, click the New Sheet button, which is 
located after the last worksheet tab. Figure 1-4 shows how. To delete a worksheet, 
just right-click the worksheet’s tab and select Delete from the menu.

Don’t delete a worksheet unless you really mean to. You cannot get it back after it 
is gone. It does not go into the Windows Recycle Bin.

You can insert many new worksheets. The limit as to how many is based on your 
computer’s memory, but you should have no problem inserting 200 or more. Of 
course, I hope you have a good reason for having so many, which brings me to the 
next point.

Worksheets enable you to organize your data. Use them wisely and you will find 
it easy to manage your data. For example, say that you are the boss (I thought 
you’d like that!), and over the course of a year you track information about 30 
employees. You may have 30 worksheets — one for each employee. Or you may 
have 12 worksheets — one for each month. Or you may just keep it all on one 
worksheet. How you use Excel is up to you, but Excel is ready to handle whatever 
you throw at it.

You can set how many worksheets a new workbook has as the default. To do this, 
click the File tab, click Options, and then click the General tab. Under the When 
Creating New Workbooks section, use the Include This Many Sheets spinner con-
trol to select a number.

Introducing the Formulas tab
Without further ado, I present the Formulas tab of the Ribbon. The Ribbon sits at 
the top of Excel. Items on the Ribbon appear as menu headers along the top of the 
Excel screen, but they actually work more like tabs. Click them and no menus 
appear. Instead, the Ribbon presents the items that are related to the clicked 
Ribbon tab.

FIGURE 1-4: 
Inserting a new 

worksheet.
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Figure  1-5 shows the top part of the screen, in which the Ribbon displays the 
items that appear when you click the Formulas tab. In the figure, the Formulas tab 
is set to show formula-based methods. At the left end of the tab, functions are 
categorized. One of the categories is opened to show how you can access a particu-
lar function.

These groups are along the bottom of the Formulas tab:

»» Function Library: This includes the Function Wizard, the AutoSum feature, 
and the categorized functions.

»» Defined Names: These features manage named areas, which are cells or ranges 
on worksheets to which you assign a meaningful name for easy reference.

»» Formula Auditing: These features are for checking and correcting formulas. 
Also here is the Watch Window, which lets you keep an eye on the values in 
designated cells, but within one window. In Figure 1-6 you can see that a few 
cells have been assigned to the Watch Window. If any values change, you can 
see this in the Watch Window. Note how the watched cells are on sheets that 
are not the current active sheet. Neat! By the way, you can move the Watch 
Window around the screen by clicking the title area of the window and 
dragging it with the mouse.

FIGURE 1-5: 
Getting to know 

the Ribbon.
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»» Calculation: This is where you manage calculation settings, such as whether 
calculation is automatic or manual.

Another great feature that goes hand in hand with the Ribbon is the Quick Access 
Toolbar. (So there is a toolbar after all!) In Figure 1-5, the Quick Access Toolbar 
sits just above the left side of the Ribbon. On it are icons that perform actions with 
a single click. The icons are ones you select by using the Quick Access Toolbar tab 
in the Excel Options dialog box. You can put the toolbar above or below the Ribbon 
by clicking the Customize Quick Access Toolbar drop-down arrow on the Quick 
Access Toolbar and choosing an option. In this area, too, are the other options for 
the Quick Access Toolbar.

Working with rows, columns,  
cells, ranges, and tables
A worksheet contains cells. Lots of them. Billions of them. This may seem unman-
ageable but actually it’s pretty straightforward. Figure 1-7 shows a worksheet that 
contains data. Use this to look at a worksheet’s components. Each cell can contain 
data or a formula. In Figure 1-7, the cells contain data. Some, or even all, cells can 
contain formulas, but that’s not the case here.

Columns have letter headers — A, B, C, and so on. You can see these listed hori-
zontally just above the area where the cells are. After you get past the 26th col-
umn, a double lettering system is used — AA, AB, and so on. After all the two-letter 
combinations are used up, a triple-letter scheme is used. Rows are listed vertically 
down the left side of the screen and use a numbering system.

You find cells at the intersection of rows and columns. Cell A1 is the cell at the 
intersection of column A and row 1. A1 is the cell’s address. There is always an 
active cell — that is, a cell in which any entry would go into should you start typ-
ing. The active cell has a border around it. Also, the contents of the active cell 
appear in the Formula Box.

FIGURE 1-6: 
Eyeing the 

Watch Window.
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When I speak of, or reference, a cell, I am referring to its address. The address is 
the intersection of a column and row. To talk about cell D20 means to talk about 
the cell that you find at the intersection of column D and row 20.

In Figure 1-7, the active cell is C7. You have a couple of ways to see this. For start-
ers, cell C7 has a border around it. Also notice that the column head C is shaded, 
as well as row number 7. Just above the column headers are the Name Box and the 
Formula Box. The Name Box is all the way to the left and shows the active cell’s 
address of C7. To the right of the Name Box, the Formula Box shows the contents 
of cell C7.

GETTING TO KNOW THE FORMULA BAR
Taken together, the Formula Box and the Name Box make up the Formula Bar. You use 
the Formula Bar quite a bit as you work with formulas and functions. The Formula Box 
is used to enter and edit formulas. The Formula Box is the long entry box that starts in 
the middle of the bar. When you enter a formula into this box, you can click the little 
check-mark button to finish the entry. The check-mark button is enabled only when you 
are entering a formula. Pressing Enter also completes your entry; clicking the X cancels 
the entry.

FIGURE 1-7: 
Looking at what 

goes into a 
worksheet.


