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LTspice, developed by Analog Devices, is a powerful, fast, and free SPICE 
simulator, schematic capture, and waveform viewer with a large database of 
components supported by SPICE models from all over the world. Drawing 
a schematic in LTspice is easy and fast. Thanks to its powerful graphing 
features, you can visualize the voltages and currents in a circuit, and also
the power consumption of its components and much more.

This book is about learning to design and simulate electronic circuits 
using LTspice. Among others, the following topics are treated:

> DC and AC circuits
> Signal diodes and Zener diodes
> Transistor circuits including 

oscillators
> Thyristor/SCR, diac, and triac 

circuits
> Operational amplifier circuits 

including oscillators

> The 555 timer IC
> Filters 
> Voltage regulators
> Optocouplers
> Waveform generation
> Digital logic simulation 

including the 74HC family
> SPICE modeling

LTspice is a powerful electronic circuit simulation tool with many features 
and possibilities. Covering them all in detail is not possible in a book of this 
size. Therefore, this book presents the most common topics like DC and
AC circuit analysis, parameter sweeping, transfer functions, oscillators, 
graphing, etc. Although this book is an introduction to LTspice, it covers 
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operation principles. Readers who want to dive deeper can find many 
detailed  tutorials, articles, videos, design files, and SPICE circuit models
on the Internet.

All the simulation examples used in the book are available as files at the 
webpage of this book. Readers can use these example circuits for  learning 
or modify them for their own applications.
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Preface

Electronic circuit simulation is essential in all branches of electrical and electronic engineering. 
Students put into practice the complex theory they have learned in their courses, and this 
gives them the chance to apply the theory to real-world experiments. Practicing engineers 
simulate and optimize electronic circuits before constructing them for final testing.

Circuit theory is a core subject that is the fundamental part of all electrical and electronic 
engineering courses. In conventional engineering laboratory experiments, electronic 
components and instruments must be purchased and then assembled to build circuits for 
experimentation and validation. Usually, it may be costly and sometimes difficult to obtain 
the real components required for an experiment, especially during the development cycle. 
Simulating a circuit is much cheaper and faster. Components and instruments cannot be 
broken and an unlimited amount of them is available.

LTspice, developed by Analog Devices, is a powerful, fast, and free SPICE simulator, 
schematic capture, and waveform viewer with a large database of components supported 
by SPICE models from all over the world. Drawing a schematic in LTspice is easy and fast. 
Thanks to its powerful graphing features, you can visualize the voltages and currents in a 
circuit, and also the power consumption of its components and much more.

LTspice is a powerful electronic circuit simulation tool with many features and possibilities. 
Covering them all in detail is not possible in a book of this size. Therefore, this book presents 
the most common topics like DC and AC circuit analysis, parameter sweeping, transfer 
functions, oscillators, graphing, etc. Although this book is an introduction to LTspice, it 
covers most topics of interest to people engaged in electronic circuit simulation.

The book is aimed at electronic/electrical engineers, students, teachers, and hobbyists. 
Many tested simulation examples are given in the book. Readers do not need to have any 
computer programming skills, but it will help if they are familiar with basic electronic circuit 
design and operation principles. Readers who want to dive deeper can find many detailed 
tutorials, articles, videos, design files, and SPICE circuit models on the Internet.

All the simulation examples used in the book are available as files at the webpage of this 
book. Readers can use these example circuits for learning or modify them for their own 
applications.

I hope you enjoy reading the book and use LTspice in your next electrical/electronic 
simulation project.

Prof Dogan Ibrahim
April 2024
London
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Chapter 1 • Introduction

1.1 Why simulate?
One of the major differences of engineering courses from many other courses is that 
engineering courses highly depend on practical work, such as laboratory work. Laboratories 
are essential parts of every engineering course, and it is a major requirement for all students 
in such courses to complete all laboratory work successfully before they are allowed to 
graduate.

Students learn the mathematics and theories of electronics in classes, and they are then 
expected to apply this knowledge by carrying out relevant experiments in the lab. This is 
true for all engineering courses, whether it is chemical engineering, mechanical engineering, 
electrical/electronic engineering, etc. For example, electronic engineering students learn the 
circuit theory in great detail in the class. They are then expected to carry out experiments 
in laboratories using real components, real measuring tools, and real power supplies and 
put the learned theories into practice.

Although real laboratory experiments are very useful, they have some problems associated 
with them:

•	The purchase of real electronic components and instruments can be very 
costly. Many pieces of the same instruments are usually required for a class of 
students, and this can be very costly.

•	The characteristics of electronic components and electronic equipment can 
change with aging and temperature and as a result, unexpected or wrong 
results can be obtained.

•	It is not always easy to find the required components, and students may have 
to wait for long times before they can develop and test their projects. For 
example, an experiment may require a certain model of transistor and this 
transistor may not be available in the laboratory stock.

•	Real components and real equipment can easily be damaged by improper use, 
for example by applying large voltages, or by passing large currents through 
them, or by short-circuiting them. It may be costly to replace or repair them in 
time.

•	Students can get accidents (e.g. electric shock) in laboratories by not following 
the safety regulations. Thus, an instructor must always be present in a 
laboratory to make sure that students connect the components correctly and 
use the mains-powered instruments by following the established safety rules.

•	Laboratory instruments usually need to be recalibrated from time to time and 
this can be costly and also inconvenient.
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•	Students following distant education courses may not be able to attend 
laboratories.

Computer simulation is an alternative to carrying out experiments using real hardware. A 
simulator is basically a computer program that predicts the behavior of a real electronic 
circuit. Software models (e.g. SPICE models) of real components and virtual instruments 
are used in a simulation. Typically, in a simulation, students run the simulator program and 
pick the required components and virtual instruments from a software library. For example, 
the value of a resistor can be changed by the click of a button. Students then connect the 
components and the instruments by using the provided software tools to build the circuit. 
The simulation process is then activated and the AC- and DC response, transient response, 
noise response, Fourier transform, and many other responses of the circuit can easily be 
tabulated, plotted, or recorded.

Although simulation is an alternative and an invaluable tool in designing and developing 
electronic circuits. Some of its advantages are:

•	Any component, whatever its cost, can be modeled and simulated. Virtual 
instruments are computer programs and thus there are no cost issues.

•	Virtual instruments and components used in a simulation cannot be damaged 
by connecting wrongly or by applying large voltages or passing large currents 
through them.

•	Simulator instruments do not need calibration, since they’re simply computer 
programs. They are available at all times and always operate with the same 
specifications.

•	Simulation allows measurements of internal currents and voltages in a circuit 
that can be complicated or even impossible to do when using real components. 
For example, the voltage across part of a circuit could be very large and provide 
a health hazard.

•	Simulation can easily be used in distant education courses. Students can be 
supplied with copies of the simulator program, or they can be given access 
codes to use a simulator program over the web. LTspice is a freely available 
circuit simulator program, and it can be used by all students. Experiments can 
then be carried at e.g. home and at any moment.

However, simulation also has some inconveniences:

•	A simulation is only as good as its model. Simulation does not usually consider 
the component tolerances, aging, or temperature effects. Users may think that 
all components are ideal at all times.
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•	Simulation results may not be accurate at very high frequencies. For example, 
concepts like the skin effect are not normally considered in a high-frequency 
simulation.

•	A simulator may have bugs or particularities that may result in incorrect results 
when not dealt with properly.

•	Simulation programs constantly evolve as new components and features are 
introduced and bugs are corrected. This requires updating the software from 
time to time.

1.2 Electronic Simulation
The history of electronic simulation dates back to the 1970s. Before the availability of 
personal computers, electronic simulation was carried out in analog form using operational 
amplifiers and passive components. This type of simulation was very limited, was not 
accurate, and was mainly used in analyzing automatic control systems.

One of the earliest simulation programs was SPICE (Simulation Program with Integrated 
Circuit Emphasis), designed to simulate analog electronic circuits. Developed at the 
U. C. Berkeley in the late 1960s, version 2 of SPICE was released to the public domain. 
Version 3 was released in March 1985. This version was written in FORTRAN, which was the 
most commonly used programming language at the time.

Most professional electronic simulation programs nowadays are based on SPICE. There are 
many sources of information on SPICE modeling on the Internet, such as books, tutorials, 
videos, examples, and interested readers should refer to them. Also, Chapter 13 of this 
book is devoted to SPICE modeling.

1.3 The LTspice Simulator
There are many professional circuit simulators in the market, and some can be quite 
expensive. Some educational establishments or private individuals offer simulators free of 
charge that can be downloaded from the Internet. Some currently available popular circuit 
simulators are: LTspice, TINA, Altium, Proteus, PSPICE, SiMetrix, CircuitLab, Multisim, 
PLECS, CircuitLogix, and many others. 

LTspice is a simulator developed by and made available for free by Linear Technology, now 
Analog Devices. Some features of LTspice are summarized in the next sections.

1.3.1 Schematic capture
Circuit diagrams are entered using an easy to use schematic editor. Component symbols 
chosen from the Component bar are positioned, moved, rotated and/or mirrored on the 
screen easily by the mouse and keyboard. LTspice’s component catalog includes many 
electronic components. Thousands of additional components can be added from many 
sources on the Internet. You can open any number of circuit files or subcircuits, cut, copy 
and paste circuit segments from one circuit into another, and, of course, analyze any of 
the currently open circuits. LTspice makes it straightforward to create blocks of electronic 
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circuits (called subcircuits or hierarchical blocks) that can be included in other circuits so 
that large circuits can be constructed from simple blocks. For example, you can create 
a block of a second order low-pass filter and then make higher order low-pass filters by 
simply cascading such blocks.

1.3.2 DC analysis 
The DC analysis calculates the DC operating point and the transfer characteristic of analog 
or digital circuits. The user can inspect the calculated (“measured”) DC nodal voltages and 
loop currents at any node or mesh by tabulating a list of all currents and voltages in the 
circuit.

1.3.3 AC analysis 
The AC analysis allows calculating and plotting complex voltage, current, and power transfer 
functions. Bode diagrams with a logarithmic frequency axis and a decibel vertical axis are 
easily drawn.

1.3.4 Transient analysis
The transient analysis lets you calculate and then plot the circuit response against time. 
Users have the option of simulating using sine wave input, pulse input, piece-wise-linear 
input or any other type of user-defined input from a file.

1.3.5 Plotting the results
The waveform plotting options of LTspice are powerful. They allow the time or frequency 
responses to be plotted of any point in a circuit by simply clicking on the desired point. In 
addition to current and voltage plot, the power consumption can also be plotted easily by 
simply clicking on a component whose power dissipation is to be plotted. You can display 
the frequency of a waveform, its peak value and display the voltage or time at any point of 
a voltage, current, or power curve. You can zoom in or out any part of a waveform, change 
the color of waveforms plotted, insert text, plot multiple waveforms on the same graph, 
plot waveforms on top of each other in different graphs, etc.

1.3.6 Transient noise analysis
With LTspice you can analyze the noise at the input or output of a circuit and plot it. 

1.3.7 Fourier analysis (FFT)
In addition to the calculation and display of the responses, the Fast Fourier Transform (FFT) 
of an output can easily be plotted.

1.3.8 Digital simulation
LTspice includes tools to simulate digital circuits. Although the supplied number of digital 
components is rather limited, thousands of digital components can easily be imported and 
used.

1.3.9 Laplace transform based analysis
LTspice enables a circuit transfer function represented in Laplace transform to be used in 
a simulation.

Boek LTspice Essentiels-UK 240430.indd   14Boek LTspice Essentiels-UK 240430.indd   14 29-05-2024   15:5529-05-2024   15:55



Chapter 1 • Introduction

● 15

1.3.10 Expression editor
The Expression Editor is a powerful tool enabling mathematical operations to be performed 
on any waveform. For example, with the help of the Expression Editor, two waveforms can 
be multiplied and the result plotted.

1.3.11 Parameter sweeping
In addition to voltage sweeping, LTspice allows users to change the values of components 
and carry out parameter sweeping analysis by plotting the results.

1.3.12 AC sweep
LTspice allows AC sweeping to be carried out for linear, octave, and decade sweeps.

1.3.13 DC sweep 
DC sweep allows you to do various sweeps of your circuit to see how it responds to various 
conditions. The sweep is available for voltage, current, and temperature.

1.3.14 SPICE models
There are thousands of freely available compatible SPICE component models that can be 
used with LTspice. Additionally, you can create and use your own models.

1.3.15 Netlist
You can export SPICE the netlist of your schematic so that they can be used for example 
with a PCB design program.

1.3.16 Online help
Detailed online help is available by pressing the F2 button. Additionally, there are many 
tutorials, books, YouTube videos, example simulations, and articles on the Internet free of 
charge for interested readers. 	
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Chapter 2 • Getting Started with LTspice

2.1 Overview
In this chapter, you will be learning how to install the latest version of LTspice on a computer 
running Windows (it can also be installed on macOS  10.14 and forward). Additionally, 
you will be learning how to use some of its menu options. At the end of this chapter, we 
will draw the schematic of an interesting multivibrator circuit and then simulate it using 
LTspice. In the remaining chapters of the book, detailed schematic drawing and simulation 
techniques will be discussed starting from the first principles.

2.2 Installing LTspice on Windows
At the time of writing this book, the latest version of LTspice was 24.0.9, known as 
Version 24. The installation steps are:

•	Go to the website:
https://www.analog.com/en/resources/design-tools-and-calculators/
LTspice-simulator.html

•	Scroll down and click on the Download link to download the installation file 
(Figure 2.1). At the time of writing this book, the installation file was named 
(for 64-bit PCs): LTspice64.msi

Figure 2.1 Click to download the installation file

•	Double-click on the file to install LTspice. After the installation, the icon shown 
in Figure 2.2 should appear on your desktop,

Figure 2.2 LTspice icon

2.3 Running LTspice
Double-click on the icon to start LTspice. Figure 2.3 shows the start-up screen. At this 
stage, you will see that almost all the menu options are grayed out and are not available, 
except for File, View, Tools, and Help. We will cover these options in a later chapter. For 
now, click Help → About LTspice to display the version number (Figure 2.4)
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Figure 2.3 LTspice startup screen

Figure 2.4 LTspice version number

2.4 Creating a New Schematic
Before creating a new schematic, it is important to know how to specify the values of 
resistors, capacitors, and inductors to be used in our circuit. Table 2.1 shows the available 
value prefixes. Note that they are not case-sensitive. For example, k and K are both 
interpreted as kilo.

Prefix Name Multiplier

T tera 1012

G giga 109

Meg mega 106

k kilo 103

m milli 10-3

u micro 10-6

n nano 10-9

p pico 10-12

f femto 10-15

Table 2.1 LTspice units

Chapter 2 • Getting Started with LTspice
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To create a new schematic, click File → New Schematic, or press Ctrl+N, or click the icon 
with the ‘+’ sign at the left-hand side of the top menu. You will be presented with a screen 
as shown in Figure 2.5. At the top part of the screen, we have the menu items and below 
them are the buttons or icons (in the figure, the screen is cut into two for clearness). A 
function brief is shown for each button as a quick reference. 

Figure 2.5 New schematic screen

The following key combinations can be used to access the menu buttons (in between 
parentheses are the LTspice  XVII ‘classic’ keyboard shortcuts. They can be activated 
through the Tools → Settings menu, on the Schematic tab and then the Keyboard 
Shortcuts button):

New schematic	 -	 Ctrl+N
Open		  - 	 Ctrl+O
Save		  -	 Ctrl+S
Print		  -	 Ctrl+P
Configure analysis	 -	 A (n/a)
Zoom		  -	 Z (Ctrl+Z)
Zoom back		  -	 Shift+Z (Ctrl+B)
Zoom to fit		  -	 Space (n/a)
Wire		  -	 W (F3)
Ground		  -	 G
Resistor		  -	 R
Capacitor		  -	 C
Inductor		  -	 I
Diode		  -	 D
Component		  -	 P (F2)
Label net		  -	 N (F4)
Text			  -	 T
Spice directive	 -	 . (S)
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Delete mode		 -	 DEL (DEL or F5)
Duplicate mode	 -	 Ctrl+C (F6)
Move mode		  -	 M (F7)
Stretch mode	 -	 S (F8)
Search		  -	 Ctrl+F

Example schematic
Perhaps the easiest way to learn how to create a schematic is to go through an example 
circuit. The schematic we will be drawing is a multivibrator circuit (also known as an astable 
circuit), taken from the LTspice Educational Examples folder. The multivibrator is a simple 
square wave oscillator circuit with two transistors, four resistors, and two capacitors, and of 
course, a power supply (e.g. a battery). The actual operation of the circuit is not relevant at 
this stage, and the author assumes that most readers are familiar with multivibrator circuits. 
A step-by-step approach is given below that explains how to draw and then simulate the 
circuit shown in Figure 2.6.

Figure 2.6 Example multivibrator circuit

•	Start LTspice.

•	Click File → New Schematic.

•	We will make the wire color black, and the screen background color white, to 
improve visibility for this book. To change the wire color, click Tools → Color 
Preferences, Select Wires as the Selected item and set the red, green 
and blue to 0 so that the wire color is black. Also, select Background as the 
Selected item and set Red, Green and Blue to 255 so that the background 
color is white.

•	You can also make the graph lines thicker by clicking Tools → Settings and 
then click to select tab Waveforms. Set the Data trace width to a higher 
value (e.g. 3).

•	Click on the resistor symbol and place resistors R1, R2, R3 and R4 
approximately at the same positions as in Figure 2.6 (See Figure 2.7). Press 
ESC on the keyboard or do a right-click to exit. You can zoom in or out by 
scrolling the mouse wheel. Move the drawing by pressing the left mouse 
button and keeping it pressed down. If you want to change the position of a 
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