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How to Use This Book
Who This Book Is For 
This book is for the reader who has never used this 
particular technology or software application. It is also 
for readers who want to expand their knowledge.

The Conventions in This Book

1 Steps
This book uses a step-by-step format to guide you 
easily through each task. Numbered steps are actions 
you must do; bulleted steps clarify a point, step, or 
optional feature; and indented steps give you the 
result of the action.

2 Notes
Notes give additional information — special conditions 
that may occur during an operation, a situation that 
you want to avoid, or a cross-reference to a related 
area of the book.

3 Icons and Buttons 
Icons and buttons show you exactly what you need to 
click to perform a step.

4 Tips
Tips offer additional information, including warnings 
and shortcuts. 

5 Bold
Bold type shows command names, options, or text or 
numbers you must type.

6 Italics
Italic type introduces and defines a new term.

Entering and Editing Data chapter2
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11

33

55

33
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11
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DataData

Records
Records

B
CC
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How do 
I remove 
a sort?
Press  + 

 to undo the 
last action (the 
sort). If you 
have performed 
other actions since the sort, close the datasheet without saving 
your changes:

1 Right-click on the datasheet tab.

2 Choose Close from the shortcut menu.

3 At the prompt to save changes to the design of the table, click No.

How do I sort 
records in a 
form?
All the same 
techniques for 
sorting a 
datasheet also 
work in a form, 
even though most forms show only 
one record at a time. The sort affects 
the order in which records appear 
when you move among them by 
using the Next Record and Previous 
Record buttons. The record number 
for each record stays the same.

● A query grid appears.

3 Drag the fields you want to sort 
by into the grid — in the order by 
which you want to apply them.

4 For each field in the grid, click 
here ( ) to choose Ascending or 
Descending.

5 Click Toggle Filter.

 The datasheet is sorted by the 
fields that you specified.

Sort Records by Multiple Fields

1 Click Advanced on the Home tab.

2 Click Advanced Filter/Sort.

Sort Records by a Single Field 
(the Ribbon Method)

1 Click anywhere in the field by 
which you want to sort.

2 Click the Ascending button on 
the Home tab to sort in ascending 
order.

● Alternatively, you can sort in 
descending order by clicking the 
Descending button.

 The data is sorted.

Sort Records by a Single Field 
(the Right-Click Method)

1 Right-click anywhere in the 
column by which you want to sort.

2 Choose Sort A to Z from the 
shortcut menu to sort in 
ascending order.

● Alternatively, you can sort in 
descending order by choosing 
Sort Z to A from the shortcut 
menu.

 The data is sorted.

Note: Depending on the field type, the sort options 
may be different. For example, for a Date/Time 
field, the commands are Sort Oldest to Newest and 
Sort Newest to Oldest.

Sort Records

One way to quickly find a particular record is to 
reorder, or sort, the records by a particular field. 
You can sort by any field in either ascending (A to 
Z) or descending (Z to A) order. You can also do a 
multifield sort that specifies what field to use in the 
event of a tie in the primary sort field.

Sort 
Records

22

33

11

1
3

2

4

56
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chapter 

ABC Textbooks
Phone List

“We Teach the World”

Scott Avery 555-462-3357

Alex Lee 555-463-3455
Paige Grant 555-462-0000
Jim O’Malley 555-462-9090
Kelly Benson 555-463-9080
Anne Waters 555-462-7878Chris Tyler 555-463-1243David Smith 555-462-3528Allen Kirkley 555-462-5718Billie Eames 555-463-0382Mark Allan 555-462-4183

Phone Numbers

Getting Started 
with Access 2010

Are you new to Access or 
upgrading to the latest 
version? This chapter 
explains how to create a 
database as well as how to 
navigate through the new-
and-improved Microsoft 
Office Access 2010 interface.
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AccessAccessAccessAccessAccess
20102010201020102010

Phone Numbers

Office Mate
Address

Phone

E-mail
Fax

United Delivery
Address

Phone

E-mail
Fax

Mann Electronics

Address

Phone

E-mailFax

My DVD Collection
# 001 Summer Memories
#002 Dad’s Birthday
#003 Dance!#004 Sci-Fi Matinee

#005 A Far Planet
#006 Sing to Me, Season 1

#007 Sing to Me, Season 2

#008 Lost in New York City

#009 The 1940s in Music
#010 Late Night Nightmares

#011 London, Summer 2007

#012 Katie’s Bachelorette Party

#013 Katie & Joe’s Wedding

#014 Dark Ambition, Season 1

Custo
mer L

ist

Payroll

Microsoft Access 2010 is a program for 
creating databases to store business or personal 
data. You can use Access to create, retrieve, and 
manage large or small collections of information.

An Introduction 
to Access 2010

Relational Databases
Microsoft Access creates relational databases — 
that is, databases that can contain multiple tables 
with links between them. For example, a business 
may have a Customers table for storing customer 
contact information and an Orders table for storing 
information about orders placed. Each customer in 
the Customers table has a unique ID, and each order 
in the Orders table references a specific customer ID.

Tables, Records, and Fields
In Access, data is stored in tables, and each individual 
entry in the table is called a record. For example, in a 
Customers table, the information about each customer 
is a separate record. Each record is composed of one 
or more fields that contain individual pieces of data. 
For example, customer fields may include Name, 
Address, City, State, and Zip Code.

Customers

ID 3251 Greiner Garden Supply
6756 Zoe Way, Chicago IL 60602

ID 3252 Growing Things
903 Gulder St., Chicago IL 60602

ID 3253 Flower Power
13 West St., Chicago IL 60612

ID 3254 Wicker Park Gardening

322 W. 9th St., Chicago IL 60603

ID 3255 Allen’s Greenhouse

4745 Brandon, Chicago IL 60602

ID 3250 The Good Earth
60 Wicker Ct., Chicago IL 60612

Orders

ID 3251 Greiner Garden Supply
01/13/09 – Order Shipped

ID 3250 The Good Earth
01/05/09 – Order Shipped

ID 3252 Growing Things
01/10/09 – Order Shipped

ID 3250 The Good Earth
01/10/09 – Back Order

ID 3254 Wicker Park Gardening01/13/09 – Order ShippedID 3252 Growing Things01/16/09 – Back OrderID 3255 Allen’s Greenhouse
01/16/09 – Order Shipped

Name Address City ZipState

Name

Table
Name Address City State Zip

RECORDS
RECORDSTABLESTABLES FIELDSFIELDS
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Datasheets and Forms
By default, each table appears as a spreadsheet grid called a 
datasheet. You can type directly into a datasheet. To make 
data entry more convenient, some people choose to create 
on-screen forms, which are like dialog boxes that prompt for 
field entries. An attractively formatted form is easier and more 
pleasant to use to enter new records than a plain datasheet.

NameJon Grey
Clayton

9a W. 8th

Address City State ZipayayCC
a W

Add
CiCC

Indiana

David
Last Name First Name City State Zip

1
2
3
4
5
6
7
8
9
10
11
12
13
14

Ronda 46140
46142
46147
46140
46143
46147
46147
46146
46147
46146
46146
46147
46140
46140

IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN

Allentown
Barrow
Clayton
Allentown
Dayton
Clayton
Clayton
Taylorville
Clayton
Taylorville
Taylorville
Clayton
AllentownAllentown

Lee
Jean
Allen
Rick
Alex
Paige
Jim
Kelly
Anne
Chris
David
Allen
Billie

Wong
Cramer
Martin
St. James
Lee
Grant
O’Malley
Benson
Waters
Tyler
Smith
Kirkley
Eames

David
Last Name First Name Cityyyy State Zipppp

1
2

4
5

8

10
11

13
14

Ronda 46140
46142

46140
46143

46146

46146
46146

46140
46140

IN
IN

IN
IN

IN

IN
IN

IN
IN

Allentown
Barrow

yy
Allentown
Daytony on

yyton
Taylorvilley orville

yton
Taylorvilleylorville
Taylorvilleaylorville

yayton
AllentownAllentown

Lee

Allen
Rick

gge
Jim

ylly
Anne
Chris

Allen
Billie

Wongg

Martin
St. James

O’MalleyMalley

Waters
Tyleryler

KirkleyKirkley
Eames

kley

Show only records in

city of  ClaytonClayton

ABC Textbooks
Phone List

“We Teach the World”

Scott Avery 555-462-3357

Alex Lee 555-463-3455
Paige Grant 555-462-0000
Jim O’Malley 555-462-9090
Kelly Benson 555-463-9080
Anne Waters 555-462-7878
Chris Tyler 555-463-1243David Smith 555-462-3528Allen Kirkley 555-462-5718Billie Eames 555-463-0382Mark Allan 555-462-4183

Phone Numbers

Filters and Queries
It is often useful to display a filtered view of a table. You can 
filter a table to show only certain records, only certain fields, or 
both. You can run a one-time filter or you can create a query, 
which is like a saved filter. Queries also enable you to combine 
data from multiple related tables into a single datasheet of results.

Reports
Tables and query results appear in plain datasheets, which 
are not very attractive when printed. Reports present data 
from tables and queries in an attractive, customizable 
format — complete with titles, headers and footers, and 
even logos and graphics.
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33 44

11

22

Start ACCESS
Start ACCESS
Start ACCESS

LaunchLaunchLaunch

A
CC

ES
S

A
CC

ES
S

A
CC

ES
S

A
CC

ES
S

CC
ES

AA
CC

ES
SSSS

AA
CC

ES
S

CC
ES

 The Access program window 
opens.

Start Access

1 Click Start.

2 Click All Programs.

3 Click Microsoft Office.

4 Click Microsoft Access 2010.

Start and Exit Access

Before you can create or open a database file, 
you must first start Access. Access starts with the 
File menu open and the New command selected. 
From here, you can create a new database or 
open an existing one. When you are finished 
working with Access, you should exit the 
program.

Start and Exit 
Access
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22

11

11

How is the File tab different from the tabs?
The File tab in Access 2010 opens a menu, with 
commands arranged vertically. Each command 
displays different options. It is equivalent to the 
Office button’s menu in Access 2007. 

● To open the File menu, click the File tab.

● To close the File menu, click any other tab (Home, 
for example).

Exit Access by Using 
the File Menu

1 Click File.

2 Click Exit.

 Access closes, returning you to 
your desktop view.

Exit Access by Using the 
Close Button

1 Click the Close button ( ).

 Access closes, returning you to 
your desktop view.
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44

55

22

11

33

● A new database opens, with a 
new blank table started.

1 Click File.

2 Click New.

3 Click Blank Database.

4 Type a file name for the database.

5 Click Create.

Create a Blank Database

A blank database contains only a single blank 
table and no other database objects, such as 
queries or forms. It provides the freedom to 
create exactly the objects that you want for 
your project.

Create a Blank 
Database
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11

22

Close a Database

2 Click Close Database. 

 The File menu stays open, and the 
New command becomes selected.

1 Click File. 

 The File menu opens.

You can close a database without closing Access 2010 
itself. Multiple databases can be open at once, each in its 
own copy of the application, but closing a database when 
you are finished with it frees up your computer’s memory.

Close a 
Database
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11

22

33

Te
m

pl
at

es

torytorytorytotory
ContactsContactsFirst NameLast NameE-mail AddressJob Title

CompanyBusiness PhoneHome PhoneMobile PhoneFax NumberExt. Number

1 Click File.

2 Click New.

3 Click the template category that 
you want.

● Sample templates are Microsoft-
supplied templates stored on your 
hard disk.

● Office Online Templates are 
available from the Internet if you 
are connected.

Create a Database by Using a Template

You can create a new database based on a 
template. Templates provide a jumpstart in 
creating a database by supplying tables, 
forms, and queries that you are likely to need.

Create a Database by 
Using a Template
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44

55

66

What do I do if a Welcome or Getting Started 
tab or window appears in the new database?
Just follow the prompts that appear. Depending on 
the template, there may be instructions to read, a 
video to play, or Web hyperlinks to explore.

4 Click the template that best 
matches your needs.

Note: Under Sample Templates is a Northwind 
Traders template, which provides sample data and 
many objects. This database is used for many of 
the examples in this book.

● The screen for the template 
category that you chose appears 
on the right.

5 Type a name for the database file 
or accept the default name.

6 Click Download.

Note: If you chose a template stored on your local 
hard drive, the button name in step 6 is Create.

● If you chose an online template, it 
is downloaded from the Internet.

● A form opens. Its appearance 
depends on the template that 
you chose.
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11
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David
Last Name First Name City State Zip

1
2
3
4
5
6
7
8
9
10
11
12
13
14

Ronda 46140
46142
46147
46140
46143
46147
46147
46146
46147
46146
46146
46147
46140
46140

IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN

Allentown
Barrow
Clayton
Allentown
Dayton
Clayton
Clayton
Taylorville
Clayton
Taylorville
Taylorville
Clayton
AllentownAllentown

Lee
Jean
Allen
Rick
Alex
Paige
Jim
Kelly
Anne
Chris
David
Allen
Billie

Wong
Cramer
Martin
St. James
Lee
Grant
O’Malley
Benson
Waters
Tyler
Smith
Kirkley
Eames

 The Open dialog box opens.

● If necessary, you can navigate to a 
different location.

4 Click the name of the file that you 
want to open.

5 Click Open.

 The database file opens.

Browse for and Open 
a Database File

1 Click File. 

2 Click Recent.

● If the desired file appears in the 
Recent Databases list, click it — 
and you’re done. Otherwise, 
proceed to the next step.

3 Click Open.

Note: You can also press  +  instead of 
performing steps 1 and 2.

Open a Database File

You can open a database that you previously created 
to continue developing its structure, typing data in it, 
or analyzing its data. Database files can be stored on a 
local hard drive or on a network or SharePoint server.

Open a 
Database File
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How can I prevent the 
security alert from 
appearing?
After the first time you click 
Enable Content for a 
document that contains 
macros, the warning will not 
reappear for that document. 
If the warning pertains to an 
untrusted location rather than a document with 
macros, you can prevent the security alert by 
adding the location to your Trusted Locations list. 
To do this, see Chapter 17.

Why does the Security 
Warning message bar 
appear?
A security warning appears 
when you are opening a 
database that is stored in a 
location that is not trusted, 
such as a file you received as 
an e-mail attachment, or when 
opening a file that contains macros (sets of 
recorded actions). The message implies that the 
file contains dangerous content, but that is not 
necessarily so; even a blank database can trigger 
this warning. 

If a Security Warning Message 
Bar Appears

● Click Enable Content.

 The message bar closes and the 
content is enabled.
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Access 2010 has a user interface consistent with those of 
other Office 2010 applications, including Word and Excel. 
It contains tabs, a multiple-tabbed Ribbon, and a status bar.

Understanding the 
Access 2010 Interface

Understanding the Access 2010 Interface 

● File displays a 
menu of database 
commands.

● Tabs contain 
buttons and other 
controls for working 
with data.

● The Ribbon displays 
and organizes tabs.

● Groups organize 
controls into 
sections within tabs.

● Clicking this icon 
opens a dialog box 
related to the 
group.

● The Record selector 
displays the current 
record number 
and allows you to 
navigate to other 
records.
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