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Introduction

Do you need to get your work done with Excel—smoothly, confidently, and as quickly  
as possible?

If so, you’ve picked up the right book.

Who Is This Book For?
This book is designed to help beginning and intermediate users get up to speed quickly with 
Excel 2016 for Mac and immediately become productive with it.

If you need to learn to use Excel to accomplish everyday tasks, at work or at home, you’ll 
benefit from this book’s focused approach and detailed advice. You can either start from 
the beginning of the book and work through the chapters in sequence, or use the Table of 
Contents or the Index to find the topic you need immediately, and then jump right in there.

What Does This Book Cover?
This book contains three parts that cover everything you need to know to use Excel 2016 
effectively.

Part 1, “Becoming Proficient with Excel for Mac,” makes sure you know essential moves for 
using Excel:

	Chapter 1, “Learning the Secrets of the Excel for Mac Interface,” 
teaches you the ins and outs of the three main means of controlling 
Excel: the Ribbon, the menus on the menu bar, and keyboard shortcuts. 
You grasp how to navigate through worksheets and workbooks; learn 
about quick ways of entering text in workbooks; and use splitting, 
freezing, and custom views to display exactly the items you need.

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
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	Chapter 2, “Configuring Excel to Suit the Way You Work,” shows 
you how to make Excel work your way by setting the most important 
preferences and by creating custom keyboard shortcuts for menu  
items. You also learn how to open workbooks automatically when you 
launch Excel.

	Chapter 3, “Creating Effective Workbooks and Templates,” explains 
how to create workbooks in which you can enter, edit, and manipulate 
data quickly and effectively. You learn which file formats to save the 
workbooks in, how to add property information to help you identify 
workbooks when searching, and how to make the most of templates—
including creating templates of your own. You also learn how to organize 
worksheets, lay data out effectively, define named ranges to make 
navigation easier, and create a collapsible worksheet.

	Chapter 4, “Formatting Your Worksheets Quickly and Efficiently,” 
shows you how to format worksheets quickly and efficiently using the 
various tools that Excel provides. We start with formatting rows and 
columns—everything from changing column width and row height to 
inserting and deleting rows and columns and hiding sensitive data. Then 
we go through how to apply straightforward formatting, how to apply 
conditional formatting to quickly flag values that need attention, and 
how to use data validation to check for invalid entries. Finally, we cover 
how to save time by using table formatting or Excel’s styles, and how to 
add headers and footers to worksheets.

Part 2, “Performing Calculations and Presenting Data,” gets you up to speed with formulas, 
functions, charts, and graphical elements such as pictures and sparklines:

	Chapter 5, “Performing Custom Calculations with Formulas,” makes 
sure you know what formulas and functions are, and what the difference 
between the two is. This chapter then teaches you how to create 
your own formulas using Excel’s calculation operators, starting with 
straightforward formulas that use a single calculation operator each, and 
then moving on to more complex formulas that use multiple calculation 
operators. You also learn how to override Excel’s default order for 
evaluating operators and how to troubleshoot common problems that 
occur with formulas.

	Chapter 6, “Using Excel’s Built-In Functions,” explains how to insert 
functions in your worksheets using the various tools that Excel provides, 
find the functions you want, and point the functions to the data they 
need for the calculations. The second part of the chapter reviews Excel’s 
different categories of functions, such as database functions, logical 
functions, and math and trigonometric functions, and gives examples of 
how to use widely used functions.

http://dx.doi.org/10.1007/978-1-4842-1019-2_2
http://dx.doi.org/10.1007/978-1-4842-1019-2_3
http://dx.doi.org/10.1007/978-1-4842-1019-2_4
http://dx.doi.org/10.1007/978-1-4842-1019-2_5
http://dx.doi.org/10.1007/978-1-4842-1019-2_6
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	Chapter 7, “Creating Clear and Persuasive Charts,” teaches you how 
to present data clearly and persuasively using Excel’s wide range of 
charts. You learn the different ways you can place charts in worksheets, 
the components of charts, and the types of charts you can use. We then 
dig into how you create a chart from your data, lay it out the way you 
want, and then give it the look it needs. We also look at ways of reusing 
the custom charts you create and ways of using Excel charts in Word 
documents or PowerPoint presentations.

	Chapter 8, “Using Data Bars, Color Scales, Icon Sets, and Sparklines,” 
shows you how to add visual appeal to your worksheets by using those 
four types of single-cell graphical elements. You quickly get the hang 
of using data bars to compare the values in a range of cells, adding 
color scales to adjust the background colors of cells to provide a visual 
reference to their values, and using icon sets to provide quick visual 
reference to performance. And you learn to create single-cell charts 
using sparklines.

	Chapter 9, “Illustrating Your Worksheets with Pictures, SmartArt, and 
More,” explains ways of giving your workbooks visual interest by adding 
graphics, shapes, SmartArt diagrams, and WordArt items. You learn how 
to make a picture look the way you want it, how to position graphical 
objects wherever you need them, and how to position graphical items 
relative to cells and how to arrange graphical objects to control which 
ones are visible.

Part 3, “Analyzing Data and Sharing and Automating Your Workbooks,” shows you how to 
analyze, manipulate, and share the workbooks you’ve built:

	Chapter 10, “Creating Databases Using Tables,” covers using Excel’s 
tables to create databases for storing information, sorting it, and filtering 
it to find the records you need. You also learn how to put Excel’s 
database functions to work with tables.

	Chapter 11, “Solving Business Questions with What-If Analysis, Goal 
Seek, and Solver,” teaches you how to analyze your data using four 
powerful tools. You learn to use data tables to assess the impact of 
one or two variables on a calculation and how to use scenarios to 
experiment with different sets of values without changing your core 
data. You also learn to use Goal Seek to solve single-variable problems 
and Solver to crack multi-variable problems.

	Chapter 12, “Analyzing Data with PivotTables,” explains what 
PivotTables are and how you can use them to examine the data in your 
worksheets and find the secrets it contains. You learn how to create 
PivotTables either using Excel’s automated tool or by placing fields 
manually where you need them, how to change the PivotTable once 
you’ve created it, and how to sort and filter the data it contains.

http://dx.doi.org/10.1007/978-1-4842-1019-2_7
http://dx.doi.org/10.1007/978-1-4842-1019-2_8
http://dx.doi.org/10.1007/978-1-4842-1019-2_9
http://dx.doi.org/10.1007/978-1-4842-1019-2_10
http://dx.doi.org/10.1007/978-1-4842-1019-2_11
http://dx.doi.org/10.1007/978-1-4842-1019-2_12
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	Chapter 13, “Collaborating and Sharing with Macs and Windows 
PCs,” takes you through ways of sharing your workbooks with others. 
We start by covering how to print worksheets, create PDF files from 
them, and export data to comma-separated values files. We then 
move on to sharing workbooks so that multiple people can work on 
them at the same time, tracking the changes if necessary so that you 
can review them. We finish by looking at how to merge changes from 
separate copies of the same workbook into one workbook and how to 
consolidate multiple worksheets into a single worksheet.

Conventions Used in This Book 
This book uses several conventions to make its meaning clear without wasting words:

	Ribbon commands. The ➤ arrow shows the sequence for choosing 
an item from the Ribbon. For example, “choose Page Layout ➤ Page 
Setup ➤ Print Area ➤ Set Print Area” means that you click the Page 
Layout tab of the Ribbon (displaying the tab’s contents), go to the Page 
Setup group, and click the Print Area button (displaying a pop-up menu), 
and then click Set Print Area.

	Menu commands. The ➤ arrow shows the sequence of commands for 
choosing an item from the menu bar. For example, “choose Data ➤ 
Data Table” means that you open the Data menu and then click the 
Data Table item on it.

	Special paragraphs. Special paragraphs present information that you 
may want to pay extra attention to. Note paragraphs contain information 
you may want to know; Tip paragraphs present techniques you may 
benefit from using; and Caution paragraphs warn you of potential 
problems.

	Check boxes. Excel uses many check boxes—the square boxes that 
can either have a check mark in them (indicating that the option is 
turned on) or not (indicating that the option is turned off). This book tells 
you to “select” a check box when you need to put a check mark in the 
check box, and to “clear” a check box when you need to remove the 
check mark from it. If the check box is already selected or cleared, you 
don’t need to change it—just make sure it’s set the right way.

	Keyboard shortcuts. In Excel, you can often save time and effort by 
using a keyboard shortcut rather than a Ribbon command or a menu 
command. This book uses + signs to represent keyboard shortcuts. For 
example, “press Cmd+S” means that you hold down the Cmd key, press 
the S key, and then release the Cmd key. “Press Cmd+Option+T” means 
that you hold down the Cmd key and the Option key, press the T key, 
and then release the Cmd key and the Option key.

http://dx.doi.org/10.1007/978-1-4842-1019-2_13
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Part I
Becoming Proficient with 
Excel for Mac 

In this part of the book, you become proficient at the essentials of Excel for Mac.

In Chapter 1, you learn the ins and outs of the three main means of controlling Excel: the 
Ribbon, the menus, and keyboard shortcuts. You grasp how to navigate through worksheets 
and workbooks; learn about quick ways to enter text in workbooks; and use splitting, 
freezing, and custom views to display exactly the items you need.

In Chapter 2, we cover how to make Excel work your way by setting the most important 
preferences and by creating custom keyboard shortcuts as needed. You also learn how to 
open workbooks automatically when you launch Excel.

In Chapter 3, you study how to create workbooks in which you can enter, edit, and 
manipulate data quickly and effectively. You learn which file formats to save the workbooks 
in, how to add property information to help you identify workbooks when searching, and 
how to make the most of templates—including creating templates of your own. You also 
learn how to organize worksheets, lay out data effectively, define named ranges to make 
navigation easier, and create a collapsible worksheet.

In Chapter 4, we go through how to format worksheets quickly and efficiently using the 
various tools that Excel provides. We start with formatting rows and columns—everything 
from changing column width and row height to inserting and deleting rows and columns 
and hiding sensitive data. Then we see how to apply straightforward formatting, how to 
apply conditional formatting to quickly flag values that need attention, and how to use data 
validation to check for invalid entries. Finally, we cover how to save time by using table 
formatting and Excel’s styles, and how to add headers and footers to worksheets.

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
http://dx.doi.org/10.1007/978-1-4842-1019-2_2
http://dx.doi.org/10.1007/978-1-4842-1019-2_3
http://dx.doi.org/10.1007/978-1-4842-1019-2_4
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Chapter 1
Learning the Secrets of the 
Excel for Mac Interface
In this chapter, you’ll learn the ins and outs of the Excel for Mac interface and the many 
secrets it holds.

We’ll start by looking at the three main ways to control Excel: the Ribbon, the menus on the 
menu bar, and keyboard shortcuts. These give you great flexibility in the way you control 
Excel, especially when you set them up as you prefer.

From there, we’ll discuss how to navigate through worksheets and workbooks. We’ll then 
go through the various ways in which you can get data into your Excel workbooks—from 
importing existing data to entering it more quickly using AutoCorrect, AutoFill, and even the 
Replace feature.

Toward the end of the chapter, I’ll show you the smart ways to view your workbooks so you 
can work quickly and efficiently. These include splitting the window to show different parts of 
the worksheet at the same time, opening extra windows, and freezing key rows and columns 
so that they stay onscreen when you scroll to other parts of the worksheet. You can even 
create custom views to keep your data laid out exactly as you need it.

Getting Ready to Learn Excel’s Secrets
You’ll probably want to have Excel running as you go through this chapter so you can try 
out the modifications and techniques that interest you. So launch Excel if it’s not already 
running: either click the Excel icon on the Dock or (if there isn’t one) click the Launchpad 
icon on the Dock to display the Launchpad screen, and then click the Excel icon on it.

When you launch Excel, the app may display the Microsoft Excel dialog box (see Figure 1-1),  
which enables you to connect to services such as OneDrive, create new documents, and 
open existing documents. If the Microsoft Excel dialog box does open, click the New tab in 
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the left column, click the Blank Workbook item, and then click the Create button. This makes 
Excel create a blank workbook rather than one based on a content template. We’ll look at 
how to use the Microsoft Excel dialog box, which is also called the Workbook Gallery, to 
create workbooks in Chapter 3.

Three Ways to Control Excel
To control Excel, you give commands. For example, when you need a new workbook, you 
give the command to create a new workbook.

In Excel 2016 (see Figure 1-2), you can give commands in three main ways:

	Menus. Like most Mac applications, Excel provides a set of menus that 
appear on the OS X menu bar when Excel is the active application. To 
give a command, you click the menu, and then click the command.

	Ribbon. The Ribbon is the main control strip in many Microsoft apps. To 
give a command, you click its button or control.

	Keyboard shortcuts. To give a command, you press the associated key 
combination.

 

Figure 1-1. If the Microsoft Excel dialog box opens when you launch Excel, click New in the left column, click Blank 
Workbook in the main section, and then click the Create button in the lower-right corner

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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Let’s dig into each of these in turn, starting with the Ribbon.

Secrets of the Ribbon
The Ribbon is the control strip that runs across the top of the Excel window below the 
window’s title bar. The Ribbon is a control bar that contains multiple tabs, each containing 
several groups of controls. At any time, the Ribbon displays one tab’s contents; to switch to 
the contents of another tab, you click that tab. As you can see in Figure 1-3, the active tab’s 
name and background appear in different colors than those of the other tabs, so you can 
easily pick it out. 

Figure 1-2. You can control Excel using the Ribbon, the menus on the menu bar, or keyboard shortcuts
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Understanding How the Ribbon’s Tabs Work
Most of the time, the Ribbon displays seven tabs that contain controls for most normal 
operations in Excel:

	Home. This tab contains controls for cut, copy, and paste; font, 
alignment, and number formatting; conditional formatting and styles; 
inserting and deleting rows, columns, and cells; and applying themes.

	Insert. This tab contains controls for inserting tables, illustrations, charts, 
sparklines (miniature charts that fit in a single cell), and slicers (a type 
of filters); comments (text attached to cells); text objects including text 
boxes, headers and footers, and WordArt decorative text; and symbol 
characters and equations.

	Page Layout. This tab contains controls for applying themes (overall 
looks), manipulating page setup, scaling the workbook to fit printed 
pages, and choosing whether to view and print gridlines and headings.

Note To make clear where you find the controls, I give Ribbon instructions in the sequence 
tab–group–control. For example, “choose Formulas ➤ Formula Auditing ➤ Trace Precedents” 
means that you click the Formulas tab to display its contents, go to the Audit Formulas group 
(without clicking it), and then click the Trace Precedents button. To follow these instructions easily, 
make sure Excel is displaying Ribbon groups. With Excel active, click Excel on the menu bar, 
and then click Preferences on the menu to open the Excel Preferences window. In the Authoring 
category, click the View icon to display the View preferences pane. In the section called “In Ribbon, 
Show,” select the Group Titles check box (placing a check in it). Then close the Excel Preferences 
window by clicking the Close button (the red button) at the left end of the window’s title bar.

Figure 1-3. The active tab of the Ribbon appears in a different color than the other tabs. Each tab contains groups of 
controls, such as buttons and pop-up menus
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	Formulas. This tab contains controls for inserting functions, working with 
named ranges, auditing formulas, and controlling how Excel performs 
calculations.

	Data. This tab contains controls for sorting and filtering data, creating 
PivotTables and performing what-if analysis, connecting to external 
data sources, validating data, and grouping and outlining worksheets. 
(Chapter 3 discusses grouping and outlining.)

	Review. This tab contains controls for checking spelling, working with 
comments, applying protection and change-tracking to a worksheet or 
workbook, and sharing a workbook.

	View. This tab contains controls for switching among workbook views; 
controlling whether the ruler, gridlines, the Formula bar, and headings 
appear on screen; zooming the window; freezing and splitting the 
window; and recording and running macros.

As well as these standard tabs, the Ribbon contains other tabs that it displays only when 
you need them. These are sometimes called context-sensitive tabs. For example, when you 
select a chart, Excel automatically displays the Chart Design tab and the Format tab (see 
Figure 1-4). 

Note In Office for Windows, the Ribbon replaces the menu bar and the toolbars completely, so 
you have to use the Ribbon unless you set up myriad keyboard shortcuts. By contrast, Office on the 
Mac still has the menus, and you can give a fair number of commands from them; in fact, some 
commands are available only from the menus, not via the Ribbon.

Figure 1-4. The Ribbon displays context-sensitive tabs when you select an object for which tabs are available. Here, 
the Chart Design tab and Format tab appear on the Ribbon because a chart is active

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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Understanding How the Ribbon’s Groups and Controls Work
Chances are you got the hang of using the Ribbon’s tabs the first time you used Excel. The 
groups and controls are a little trickier because they change depending on whether the Excel 
window is wide enough to display the entire Ribbon.

When the Excel window is wide enough, all the groups appear, and they display their 
controls—the buttons, pop-up menus, check boxes, and so on—in their most spacious 
arrangement. For example, the top part of Figure 1-5 shows the rightmost sections of the 
Home tab of the Ribbon. All the controls in (going from right to left) the Editing group, the 
Cells group, and the Styles group appear with labels, so you can easily identify each control; 
and the Styles group displays a wide panel of cell styles.

But when there’s less space, Excel gradually collapses parts of the Ribbon so as to display 
as much as possible in the available space. For example, the middle part of Figure 1-5 
shows the rightmost sections of the Home tab again, but this time the panel in the Styles 
group has gone, replaced by the Cell Styles pop-up menu.

When the window is even narrower, Excel collapses the groups and controls further. In the 
lower part of Figure 1-5, you can see that Excel has collapsed the Cells group to a single 
pop-up button that you can click to display a pop-up menu containing the buttons that 
previously appeared in it. Similarly, the Editing pop-up button replaces the Editing group, 
and the Number pop-up button replaces the Number group. The Styles group retains its 
three pop-up menus, but they now appear in a vertical stack instead of side by side.

Figure 1-5. As the Excel window becomes narrower, Excel hides first the labels for the less important controls and 
then the controls themselves, as you can see here with the controls on the right side of the Home tab of the Ribbon
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By automatically changing the Ribbon to suit the window width, Excel keeps as many 
controls as possible at the tip of your mouse. But because labels may not appear, you will 
sometimes need to display the ScreenTip to identify a control; to display the ScreenTip, hold 
the mouse pointer over the control for a moment (see Figure 1-6).

Figure 1-6. When a control’s label doesn’t appear on the Ribbon, hold the mouse pointer over the control to display a 
ScreenTip containing its name. When the Excel window is narrow, some Ribbon tabs display the arrow button shown on 
the right here, which you can click to display controls that are currently hidden

Figure 1-7. Click the Collapse Ribbon button to collapse the Ribbon to just its tabs. Click the Expand Ribbon button 
(which replaces the Collapse Ribbon button) to expand the Ribbon again

Further, because some controls may appear in different places when the Ribbon’s whole 
width isn’t displayed, you may sometimes need to hunt for the controls you need. This book 
assumes that the window is displayed wide enough for you to see all the controls on the 
Ribbon, but it notes some of the disappearing controls that can cause confusion.

If you can’t see a command that’s supposed to be there, have a poke around the remaining 
controls in the group to find where Excel has hidden the control, or to see if one of the 
controls opens a dialog box that contains the controls. (Or use the menu alternative if there 
is one.)

Collapsing the Ribbon
When you need more space to work on a worksheet, collapse the Ribbon to just its tab bar 
(see Figure 1-7) in one of these ways:

	Click the tab that’s currently active.

	Click the Collapse ribbon button (the ^ button) at the right end of the 
Ribbon.

	Choose View ➤ Ribbon from the menu bar (removing the check mark 
next to the Ribbon item).

	Press Cmd+Option+9. 


