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Who This Book Is For
This book is for the reader who has never used this 
particular technology or software application. It is 
also for readers who want to expand their knowledge.

The Conventions in This Book
1  Steps

This book uses a step‐by‐step format to guide you 
easily through each task. Numbered steps are actions 
you must do; bulleted steps clarify a point, step, or 
optional feature; and indented steps give you the 
result.

2  Notes
Notes give additional information — special 
conditions that may occur during an operation, a 
situation that you want to avoid, or a cross reference 
to a related area of the book.

3  Icons and Buttons
Icons and buttons show you exactly what you need to 
click to perform a step.

4  Tips
Tips offer additional information, including warnings 
and shortcuts.

5  Bold
Bold type shows command names, options, and text 
or numbers you must type.

6  Italics
Italic type introduces and defines a new term.

How to Use This Book

CHAPTER

13Adding Worksheet Graphics

You can improve the look of an Excel worksheet by adding a clip art image to the sheet. Clip art 
refers to small images or artwork that you can insert into your documents. Excel 2016 does not 

come with its own clip art, but it does give you access to online clip art collections that contains 
thousands of images from various categories, such as business, people, nature, and symbols. By 
default, these images are licensed under Creative Commons, so you can use them without charge.

 A Excel displays a list of clip art 
images that match your search 
term.

9 Click the clip art image you 
want to use.

 B The address of the website that 
offers the image appears here.

10 Click Insert.

Insert a Clip Art Image

The Insert Pictures window 
appears.

6 Click Bing Image Search.

7 Use the text box to type a word 
that describes the kind of clip 
art image you want to insert.

8 Click Search ( ).

1 Display the worksheet on which 
you want to insert the clip art 
image.

2 Click the cell where you want 
the upper‐left corner of the 
image to appear.

3 Click the Insert tab.

4 Click Illustrations.

5 Click Online Pictures.

Insert a Clip Art Image

 C Excel inserts the clip art.

Note: If you need to move or size 
the clip art, see the “Move or Resize 
a Graphic” section later in this 
chapter.

What is a Creative Commons license?
Creative Commons (http://creativecommons.org) is a 
non‐pro�t organization that enables artists to license 
their works for other people to use free of charge. 
There are several different Creative Commons licenses, 
so you should visit the website that offers the image 
you select to check the speci�cs of the license.

Can I insert other online images?
Yes. If you have connected your Facebook or your 
Flickr account to Windows 8 or later, you can also 
use the Facebook or Flickr option to choose a 
photo. If you are using a Microsoft account with 
Windows 8 or later, you can use the OneDrive 
option to select an image from your OneDrive.

TIPS

1

2

3 4

5
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CHAPTER  1

Working with 
Ranges
In Excel, a range is a collection of two or more cells that you work 
with as a group rather than separately. This enables you to fill the 
range with values, move or copy the range, sort the range data, and 
insert and delete ranges. You learn these and other range techniques 
in this chapter.
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Select a Rectangular Range
1  Position the mouse ( ) over 

the first cell you want to 
include in the range.

2  Click and drag the  over the 
cells that you want to include 
in the range.

A  Excel selects the cells.

3  Release the mouse button.

Select a Range of Individual 
Cells
1  Click in the first cell that you 

want to include in the range.

2  Hold down  and click in each 
of the other cells that you want 
to include in the range.

B  Each time you click in a cell, 
Excel adds it to the range.

3  Release .

Select a Range

Select a Range

To work with a range in Excel, you must first select the cells that you want to include in the range. 
After you select the range, you can fill it with data, move it to another part of the worksheet, 

format the cells, and perform the other range‐related tasks that you learn about in this chapter.

You can select a range as a rectangular group of cells, as a collection of individual cells, or as an 
entire row or column.
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CHAPTER

1Working with Ranges

Select an Entire Row
1  Position the mouse ( ) over the 

header of the row you want to 
select (  changes to ).

2  Click the row header.

C  Excel selects the entire row.

 To select multiple rows, click and 
drag across the row headers or 
hold down  and click each 
row header.

Select an Entire Column
1  Position the mouse ( ) over the 

header of the column you want 
to select (  changes to ).

2  Click the column header.

D  Excel selects the entire column.

 To select multiple columns, click 
and drag across the column 
headers, or hold down  and 
click each column header.

TIPS
Are there keyboard techniques I can use to 
select a range?
Yes. To select a rectangular range, navigate to the 
first cell that you want to include in the range, 
hold down , and then press  or  to extend 
the selection. To select an entire row, navigate to 
any cell in the row and press  + . 
To select an entire column, navigate to any cell in 
the column and then press  + .

Is there an easy way to select every cell in the 
worksheet?
Yes. There are two methods you can use. Either press 

 + , or click the Select All button ( ) in the 
upper‐left  
corner of the 
worksheet ( A ).



6

4  Release the mouse button.

A  Excel fills the range with the 
initial cell value.

Fill a Vertical or Horizontal 
Range
1  In the first cell of the range you 

want to work with, enter the data 
you want to fill.

2  Position the mouse ( ) over the 
bottom‐right corner of the cell 
(  changes to ).

3  Click and drag  down to fill a 
vertical range or across to fill  
a horizontal range.

Fill a Range with the Same Data

Fill a Range with the Same Data

If you need to fill a range with the same data, you can save time by getting Excel to fill the range 
for you. The AutoFill feature makes it easy to fill a vertical or horizontal range with the same 

value, but you can also fill any selected range. This method is much faster than manually entering 
the same data in each cell.

See the previous section, “Select a Range,” to learn how to select a range of cells.
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1Working with Ranges

Fill a Selected Range
1  Select the range you want to fill.

2  Type the text, number, or other 
data.

3  Press  + .

TIP
How do I fill a vertical or horizontal range without also copying the formatting of the original cell?
 Follow these steps:

1  Perform steps 1 to 4 to fill the data.

A  Excel displays the AutoFill Options smart tag ( ).

2  Click the AutoFill Options .

3  Click Fill Without Formatting.

 Excel removes the original cell’s formatting from 
the copied cells.

B  Excel fills the range with the 
value you typed.
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Fill a Range with a Series of Values

AutoFill a Series of Numeric, 
Date, or Alphanumeric Values
1  Click in the first cell and type the 

first value in the series.

2  Click in an adjacent cell and type 
the second value in the series.

3  Select the two cells.

4  Position the mouse ( ) over the 
bottom‐right corner of the 
second cell (  changes to ).

5  Click and drag  down to fill a 
vertical range or across to fill a 
horizontal range.

A  As you drag through each cell, 
Excel displays the series value 
that it will add to the cell.

6  Release the mouse button.

B  Excel fills the range with a series 
that continues the pattern of the 
initial two cell values.

Fill a Range with a Series of Values

If you need to fill a range with a series of values, you can save time by using the AutoFill feature 
to create the series for you. AutoFill can fill a series of numeric values such as 5, 10, 15, 20, and 

so on; a series of date values such as January 1, 2016, January 2, 2016, and so on; or a series of 
alphanumeric values such as Chapter 1, Chapter 2, Chapter 3, and so on.

You can also create your own series with a custom step value, which determines the numeric 
difference between each item in the series.
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1Working with Ranges

Fill a Custom Series  
of Values
1  Click in the first cell and type 

the first value in the series.

2  Select the range you want to 
fill, including the initial value.

3  Click the Home tab.

4  Click Fill ( ).

5  Click Series.

 The Series dialog box appears.

6  In the Type group, select the  
type of series you want to fill  
(  changes to ).

7  If you selected Date in  
step 6, select an option  
in the Date unit group  
(  changes to ).

8  In the Step value text box, 
type the value you want to use.

9  Click OK.

C  Excel fills the range with the 
series you created.

TIP
Can I create my own AutoFill series?
Yes. You can create a custom list, which is a series 
of text values. When you add the first value in your 
custom list, you can then use AutoFill to fill a 
range with the rest of the series. Follow these 
steps:

1  Click the File tab.

2  Click Options.

 The Excel Options dialog box appears.

3  Click Advanced.

4  Scroll down to the General section and then 
click Edit Custom Lists.

 The Custom Lists dialog box appears.

5  Click NEW LIST.

6  In the List entries box, type each item in your 
list, and press  after each item.

7  Click Add.

8  Click OK to return to the Excel Options dialog box.

9  Click OK.
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Flash Fill a Range

Flash Fill a Range with 
Extracted Data
1  Make sure the column of original 

data has a heading.

2  Type a heading for the column of 
extracted data.

3  Type the first value you want in 
the new column.

4  Begin typing the second value.

A  Excel recognizes the pattern and 
displays suggestions for the rest 
of the column.

5  Press .

B  Excel flash fills the column with 
the extracted data.

Flash Fill a Range

You can save time and effort by using the Flash Fill feature in Excel to automatically fill a range of 
data based on a sample pattern that you provide.

Although there are many ways to use Flash Fill, the two most common are flash filling a range with 
extracted data and flash filling a range with formatted data. For example, if you have a column of 
full names, you might want to create a new column that includes just the first names extracted from 
the original column. Similarly, if you have a column of phone numbers in the form 1234567890, you 
might want a new column that formats the numbers as (123) 456‐7890.
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1Working with Ranges

Flash Fill a Range with 
Formatted Data
1  Make sure the column of original 

data has a heading.

2  Type a heading for the new 
column of formatted data.

3  Type the first value you want in 
the new column.

4  Begin typing the second value.

C  Excel recognizes the pattern and 
displays suggestions for the rest 
of the column.

5  Press .

D  Excel flash fills the column with 
the formatted data.

TIPS
Why do I not see the automatic Flash Fill suggestions when 
I type the sample data?
For Flash Fill’s automatic suggestions to appear, you must have 
headings at the top of both the column of original data and 
the column you are using for the filled data. Also, the flash fill 
column must be adjacent to the original column and the 
sample entries you make in the fill column must occur one 
after the other. Finally, note that Flash Fill’s automatic 
suggestions usually only work with text data, not numeric data.

Can I still use Flash Fill even though I 
do not see the automatic suggestions?
Yes, you can still invoke Flash Fill on any 
range by running the Ribbon command. 
In the fill range, type the first value, 
then select that value and the rest of the 
fill range. Click the Data tab and then 
click Flash Fill ( ). Excel flash fills the 
selected range.
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Move a Range
1  Select the range you want to 

move.

2  Position the mouse ( ) over  
any outside border of the range 
(  changes to ).

3  Click and drag the range to the 
new location (  changes to ).

A  Excel displays an outline of the 
range.

B  Excel displays the address of the 
new location.

4  Release the mouse button.

C  Excel moves the range to the new 
location.

Move or Copy a Range

Move or Copy a Range

If your worksheet is not set up the way you want, you can restructure or reorganize the worksheet 
by moving an existing range to a different part of the sheet.

You can also make a copy of a range, which is a useful technique if you require a duplicate of the 
range elsewhere, or if you require a range that is similar to an existing range. In the latter case, 
after you copy the range, you can then edit the copied version of the data as needed.
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1Working with Ranges

Copy a Range
1  Select the range you want to copy.

2  Press and hold .

3  Position the mouse ( ) over any 
outside border of the range  
(  changes to ).

4  Click and drag the range to the 
location where you want the copy 
to appear.

D  Excel displays an outline of the 
range.

E  Excel displays the address of the 
new location.

5  Release the mouse button.

6  Release .

F  Excel creates a copy of the range 
in the new location.

TIPS
Can I move or copy a range to another 
worksheet?
Yes. Click and drag the range as described in 
this section. Remember to hold down  if you 
are copying the range. Press and hold  and 
then drag the mouse pointer over the tab of the 
sheet you want to use as the destination. Excel 
displays the worksheet. Release  and then 
drop the range on the worksheet.

Can I move or copy a range to another workbook?
Yes. If you can see the other workbook on‐screen, click 
and drag the range as described in this section, and 
then drop it on the other workbook. Remember to hold 
down  if you are copying the range. Otherwise, 
select the range, click the Home tab, click Cut ( ) to 
move the range or Copy ( ) to copy it, switch to the 
other workbook, select the cell where you want the 
range to appear, click Home, and then click Paste ( ).
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Insert a Row or Column

Insert a Row or Column

You can insert a row or column into your existing worksheet data to accommodate more 
information. The easiest way to add more information to a worksheet is to add it to the right 

or at the bottom of your existing data. However, you will often find that the new information you 
need to add fits naturally within the existing data. In such cases, you first need to insert a new row 
or column in your worksheet at the place where you want the new data to appear, and then add the 
new information in the blank row or column.

Insert a Row
1  Click any cell in the row below 

where you want to insert the 
new row.

2  Click the Home tab.

3  Click the Insert .

4  Click Insert Sheet Rows.

A  Excel inserts the new row.

B  The rows below the new row are 
shifted down.

5  Click the Insert Options smart 
tag ( ).

6  Select a formatting option for the 
new row (  changes to ).
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TIP
Can I insert more than one row or column at a time?
Yes. You can insert as many new rows or columns as you need. First, select the same number of rows or 
columns that you want to insert. (See the “Select a Range” section earlier in this chapter to learn how to 
select rows and columns.) For example, if you want to insert four rows, select four existing rows. For rows, 
be sure to select existing rows below where you want the new rows inserted and then follow steps 2 to 4 in 
the “Insert a Row” subsection. For columns, be sure to select existing columns to the right of where you 
want to insert the new columns and then follow steps 2 to 4 in the “Insert a Column” subsection.

Insert a Column
1  Click any cell in the row to the 

right of where you want to insert 
the new column.

2  Click the Home tab.

3  Click the Insert .

4  Click Insert Sheet Columns.

C  Excel inserts the new column.

D  The columns to the right of the 
new column are shifted to the 
right.

5  Click the Insert Options smart  
tag ( ).

6  Select a formatting option for the 
new column (  changes to ).
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Insert a Cell or Range

Insert a Cell or Range

If you need to add data to an existing range, you can insert a single cell or a range of cells within 
that range. When you insert a cell or range, Excel shifts the existing data to accommodate the 

new cells.

Although it is often easiest to create room for new data within a range by inserting an entire row 
or column, as explained in the previous section, “Insert a Row or Column,” this causes problems 
for some types of worksheet layouts. (See the first tip to learn more.) You can work around such 
problems by inserting just a cell or range.

1  Select the cell or range where 
you want the inserted cell or 
range to appear.

2  Click the Home tab.

3  Click the Insert .

4  Click Insert Cells.

Note: You can also press  
 +  + .


