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Starting up

About Digital Classroom

Adobe® After Effects® CS6 lets you create artwork for a

variety of uses. The animation and compositing tools of

After Effects are second to none; allowing you to

manipulate text, images, audio and video. After Effects

provides you with the tools to express your creative ideas

for video, film and broadband production. After Effects CS6

is also tightly integrated with other Adobe products such as

Photoshop®, Illustrator®, and Premiere Pro®.

Adobe After Effects CS6 Digital Classroom is like having

your own personal instructor guiding you through each

lesson while you work at your own speed. This book

includes 12 self-paced lessons that let you discover

essential skills and explore the new features and

capabilities of After Effects CS6 on either a Windows or

Mac OS computer. Each lesson includes step-by-step

instructions, lesson files, and video tutorials, all of which

are available on the Digital Classroom website:

www.digitalclassroombooks.com/epub/aftereffectscs6. This

book has been developed by the same team of Adobe

Certified Experts and After Effects professionals who have

created many official training titles for Adobe Systems.

Prerequisites

Before you start the lessons in Adobe After Effects CS6

Digital Classroom, you should have a working knowledge of

your computer and its operating system. You should know

how to use the directory system of your computer so that

you can navigate through folders. You need to understand

how to locate, save, and open files. You should also know

how to use your mouse to access menus and commands.

http://www.digitalclassroombooks.com/epub/aftereffectscs6


Before starting the lessons files in Adobe After Effects CS6

Digital Classroom, make sure that you have installed Adobe

After Effects CS6. The software is sold separately, and not

included with this book. You may use the 30-day trial

version of Adobe After Effects CS6 available at the

adobe.com website, subject to the terms of its license

agreement.

System requirements

Before starting the lessons in Adobe After Effects CS6

Digital Classroom, make sure that your computer is

equipped for running Adobe After Effects CS6, which you

must purchase separately. The minimum system

requirements for your computer to effectively use the

software are listed below and you can find the most current

system requirements at

www.adobe.com/products/aftereffects/tech-specs.html.

Windows

• Intel® Core™ Duo or AMD Phenom® II processor; 64-bit

support required

• Microsoft® Windows® 7 with Service Pack 1 (64 bit)

• 4GB of RAM (8GB recommended)

• 3GB of available hard-disk space; additional free space

required during installation (cannot install on removable

flash-based storage devices)

• Additional disk space for disk cache (10GB

recommended)

• 1280×900 display with OpenGL 2.0–capable system

• QuickTime 7.6.6 software required for QuickTime

features

• Broadband Internet connection required for software

activation and access to online services

Mac OS

• Multicore Intel processor with 64-bit support

http://www.adobe.com/
http://www.adobe.com/products/aftereffects/tech-specs.html


• Mac OS X v10.6.8 or v10.7

• 4GB of RAM (8GB recommended)

• 4GB of available hard-disk space for installation;

additional free space required during installation (cannot

install on a volume that uses a case-sensitive file system or

on removable flash-based storage devices)

• Additional disk space for disk cache (10GB

recommended)

• 1280×900 display with OpenGL 2.0–capable system

• QuickTime 7.6.6 software required for QuickTime

features

• Broadband Internet connection required for software

activation and access to online services

Starting Adobe After Effects CS6

As with most software, Adobe After Effects CS6 is launched

by locating the application in your Programs folder

(Windows) or Applications folder (Mac OS). If necessary,

follow these steps to start the Adobe After Effects CS6

application:

Windows

1 Choose Start > All Programs > Adobe After Effects CS6.

If you have the Creative Suite installed, you may have to

select Adobe After Effects from within the Creative Suite

folder.

2 Close the Welcome and Tip of the Day Screen when it

appears. You are now ready to use Adobe After Effects

CS6.

Mac OS

1 Open the Applications folder, and then open the Adobe

After Effects CS6 folder.

2 Double-click on the Adobe After Effects CS6 application

icon.



3 Close the Welcome and Tip of the Day Screen when it

appears. You are now ready to use Adobe After Effects

CS6.

 Menus and commands are identified throughout the

book by using the greater-than symbol (>). For

example, the command to save a project would be

identified as File > Save.

Fonts used in this book

Adobe After Effects CS6 Digital Classroom includes lessons

that refer to fonts that were installed with your copy of

Adobe After Effects CS6. If you did not install the fonts, or

have removed them from your computer, you may

substitute different fonts for the exercises or re-install the

software to access the fonts.

 If you receive a Missing layer dependencies warning

dialog when you open a file, it is usually due to not

having a necessary font installed on your system. If this

occurs, press OK and After Effects will substitute a

default system font. You can then change the default

font to one similar to the one used in the lesson.

Resetting Adobe After Effects CS6 preferences

When you start Adobe After Effects, it remembers certain

settings along with the configuration of the workspace from

the last time you used the application. It is important that

you start each lesson using the default settings so that you

do not see unexpected results when working with the

lessons in this book. Use the following steps to reset your

Adobe After Effects CS6 preferences.

Steps to reset Adobe After Effects CS6 preferences

1 Quit After Effects.



2 Locate and rename the Adobe After Effects 11.0 MC

Prefs file, as follows.

In Windows: Rename the Adobe After Effects 11.0 MC

Prefs (for example to Adobe Effects 11.0 MC Prefs-old)

in the Users/(user)/AppData/Roaming/Adobe/

After Effects/11.0

 In Windows 7, it is necessary to set hidden files to

display in the folder and search options dialog box in

order to see the AppData folder.

In Mac OS: Rename the Adobe After Effects 11.0 MC

Prefs file in the

Users/(user)/Library/Preferences/Adobe/After

Effects/11.0 folder.

3 Start After Effects. It creates a new preferences file.

 You can also reset preferences using a keyboard

shortcut. When starting the application, press and hold

Control+Alt+Shift (Windows) or

Command+Shift+Option (Mac OS). When the dialog

box appears asking if you are sure you want to delete

the preferences file press OK. Note that you have a very

short window for using this keyboard command, so do it

immediately after starting the application.

Loading lesson files

The Adobe After Effects CS6 Digital Classroom includes

files that accompany the exercises for each of the lessons.

These files are available for download at

www.digitalclassroombooks.com/epub/aftereffectscs6. You

may download all the lessons at one time or you may

choose to download and work with specific lessons.

For each lesson in the book, the files are referenced by the

file name of each file. The exact location of each file on

http://www.digitalclassroombooks.com/epub/aftereffectscs6


your computer is not used, as you may have placed the files

in a unique location on your hard drive. We suggest placing

the lesson files in the Documents folder (Windows) or at the

top level of your hard-drive (Mac OS).

Downloading and copying the lesson files to your

hard drive:

1 Use your web browser, navigate to

www.digitalclassroombooks.com/epub/aftereffectscs6.

Follow the instructions on the web page to download the

lesson files to your computer.

2 On your computer desktop, navigate to the location

where you downloaded the files and right-click (Windows)

the .zip file you downloaded, then choose Extract All or

double-click on the .zip file (Mac OS).

Working with the video tutorials

The www.digitalclassroombooks.com/epub/aftereffectscs6

site provides Adobe After Effects CS6 Digital Classroom

book readers with video tutorials that enhance the content

of this book. The videos use the popular Silverlight player

for viewing on your desktop or notebook computer, or use

iPad-compatible video if you are using an iPad to read an

electronic version of this book. Most other ePub devices are

not optimized for playing video, and you should use a

notebook, desktop, or tablet computer for viewing the video

tutorials if you are using a dedicated e-reader such as a

nook, Kindle, kobo, or Sony e-reader. An internet

connection is necessary for viewing the supplemental video

files.

The videos enhance your learning as key concepts and

instructions are discussed by the book’s authors. The video

tutorials supplement the book’s contents, and do not

replace the book. They are not intended to cover every item

discussed in the book, but will help you gain a better or

http://www.digitalclassroombooks.com/epub/aftereffectscs6
http://www.digitalclassroombooks.com/epub/aftereffectscs6


more clear understanding of topics discussed in many

lessons of the book.

Additional resources

The Digital Classroom series goes beyond the training

books. You can continue your learning online, with training

videos, at seminars and conferences, and in-person training

events.

Training from the Authors

The authors are available for professional development

training workshops for schools and companies. They also

teach classes at American Graphics Institute including

training classes and online workshops. Visit

agitraining.com for more information about Digital

Classroom author-led training classes or workshops.

Book series

Expand your knowledge of creative software applications

with the Digital Classroom training series. Books are

available for most creative software applications as well as

web design and development tools and technologies. Learn

more at DigitalClassroom.com.

Seminars and conferences

The authors of the Digital Classroom seminar series

frequently conduct in-person seminars and speak at

conferences, including the annual CRE8 Conference. Learn

more at agitraining.com and CRE8summit.com.

Resources for educators

Visit digitalclassroombooks.com to request resources for

educators, including instructors’ guides for incorporating

Digital Classroom books into your curriculum.

http://www.agitraining.com/
http://www.digitalclassroom.com/
http://www.agitraining.com/
http://www.cre8summit.com/
http://www.digitalclassroombooks.com/


Lesson 1: Understanding

Motion Graphics

This lesson provides an overview of the

various types of motion graphics and

digital video projects you can create in

After Effects. It’s filled with important

information that you need to know to

work effectively in this application. If you

can’t wait to get started using the

program, skip over this lesson for now

and jump ahead to Lesson 2,

“Understanding the After Effects

Interface.” If you jump ahead, make sure

you come back to review this lesson at a

later time.

What you’ll learn in this lesson:

• What types of content you can create in After Effects



• The properties of the video files you will be creating and

importing into After Effects

• About the various broadcast and broadband standards

that you can create content for

Starting up

This lesson includes useful background information. If

you’d prefer to jump right into working with After Effects,

you should move to the second lesson, which gets you

hands-on right away.

Defining motion graphics

Adobe After Effects is an industry standard tool for creating

motion graphics that are used for broadcast television, film,

and other motion graphics and video productions. After

Effects is used to create content that appears in

presentation graphics and on mobile devices. It is a tool for

storytelling, creating visually appealing motion graphics

that integrate into any medium to enhance a presentation,

story, image, or mood.

Television and video graphics

After Effects is an important tool for broadcast-design

professionals. It is used to create original content for

interstitial, lower thirds, bumpers, and show openings.

Many video professionals consider it an essential tool in

their daily work. In fact, you can see it at networks such as

MTV, Spike, truTV, and the Food Network, where it’s used

to produce stunning, high quality graphics and motion

design packages quickly and affordably.

Internet and mobile devices

The Internet and mobile devices are becoming a major

entertainment medium. After Effects high-quality motion

graphics are being widely used for online and mobile

content. Video sharing sites, such as Vimeo.com and

YouTube.com, provide content creators with access to a

http://vimeo.com/
http://youtube.com/


wide audience, which creates additional distribution

opportunities for individuals and organizations alike.

Desktop distribution and presentation graphics

Digital displays such as high-definition televisions,

monitors, and projectors have created new venues for

displaying motion graphics. After Effects is used to add

impact to otherwise static slides, charts, and graphs. With

the proliferation and affordability of high-definition

televisions and other digital displays, many public venues

such as: malls, retail stores, schools, and even military

bases are using motion graphics to both inform and

entertain.

Regardless of how you plan to use After Effects, you will

find it to be a powerful, well-rounded tool that, with a little

practice, can serve you well.

Digital video basics

If you want to, you can open After Effects and start

creating graphics without any understanding of how video

works. (If you really can’t wait to get started, jump ahead

to Lesson 2, “Understanding the After Effects Interface.”)

However, successfully producing graphics for video and

other media requires that you understand a few technical

requirements. If you don’t understand these, you’ll merely

be pushing buttons and clicking checkboxes, so you should

take a few minutes to at least get a foundation in digital

video.

When working in After Effects, you will want to consider

the final destination for your project. Will it be used on

television, in video, on a mobile device? Knowing this

information allows you to accurately create your After

Effects content to match your intended destination.

Projects for high-definition television differ from those for a

portable device with a small-screen. Each of these media

has its own standards for items, such as frame rate, aspect



ratio, and bit rate. Understanding these items saves you

time and effort in the production process.

Understanding video formats

Some video formats are common for professional video

production, while others are suitable only for broadband or

small-screen purposes. There are two main standards used

for broadcast television, a handful of competing standards

for desktop and web video, and a series of device-specific

standards used in mobile handheld devices. Technical

standards, such as the ones touched upon here, are very

complex, and a full description of each one is beyond the

scope of this book. In general, regardless of the platform

for which you are creating video content, there are three

main properties to keep in mind:

Dimensions: This property specifies the pixel dimensions

of a video file—the number of pixels horizontally and

vertically that make up an image or video frame. This value

is usually written as a pair of numbers separated by an x,

where the first number is the horizontal value and the

second represents the vertical value, such as 720×480. The

term Pixel is a combination of the words picture and

element and is the smallest individual component in a

digital image. Whether you are dealing with a still image or

working with video frames makes no difference; everything

displayed on-screen is made up of pixels. The dimensions of

a video or still image file determine its aspect ratio; that is,

the proportion of an image’s horizontal units to its vertical

ones. Usually written in the following format: horizontal

units:vertical units, the two most common aspect ratios

seen in current video displays are 4:3 and 16:9.

Frame rate: This property specifies the number of

individual images that make up each second of video.

Frame rate is measured as a value of fps, which is an

acronym that stands for frames per second.



Pixel aspect ratio: This property specifies the shape of the

pixels that make up an image. Pixels are the smallest part

of a digital image, and different display devices such as

televisions and computer monitors have pixels with

different horizontal and vertical proportions.

When producing graphics for broadcast television, you

have to conform to a specific set of formats and standards.

For example, you need to know whether your graphics will

be displayed on high-definition screens (1080i, 1080p,

720p), standard-definition screens, or mobile devices

because this affects the size that you must create your

graphics at. Similarly, you need to know whether you’re in

a region that broadcasts using the ATSC (often still called

NTSC) or PAL standards, as this affects both the size you

can create your graphics at, and the frame rate and pixel

aspect ratio you will need to use. If you are producing

animation or video for the Web, you’ll need to know the

format that the distributing site will be using: Flash,

Silverlight, h.264, or other, since certain video effects don’t

work well when exported to certain formats.

ATSC

In the United States, the ATSC, or Advanced Television

Systems Committee, has issued a set of standards for the

transmission of digital television. These standards have

replaced the older, analog NTSC (National Television

Standards Committee) formats. The standards embraced by

the ATSC include standard-definition and high-definition

display resolutions, aspect ratios, and frame rates. All

broadcast video and graphics must conform to one of the

ATSC standards. Information on the various ATSC

standards is available on their website at ATSC.org.

High-definition television

While high-definition (HD) television technology has existed

for decades, it wasn’t until the beginning of the 21st

http://atsc.org/


century that it came to the attention of the average

American television viewer. The term HD is used to

describe video that has a higher resolution than traditional

television systems, which are called SD, or standard

definition. There are two main high-definition standards for

broadcast television—720p and 1080i—while many

televisions, gaming consoles (Playstation 3, Xbox 360, and

more) and Blu-ray disc players can support a third, 1080p.

The letters p and I refer to whether the format uses a

progressive or an interlaced display method. Interlacing

divides each frame of video into two separate fields. When

combined, these two fields form a single video frame that

shows a single image. Progressive display forgoes fields

and has each individual frame as its own unique image. In

general, progressive displays are clearer and better

defined, while interlaced displays require less broadcast

bandwidth to be transmitted to the viewer. Most modern

video cameras allow the user to choose whether to record

in a progressive or interlaced format.

720p: The 720p format has a resolution of 1280 pixels wide

by 720 pixels high and supports a variety of frame rates,

from the 24 fps used by film, through the 30 fps that was

part of the old NTSC standard, all the way up to 60 fps.

1080p and 1080i: The 1080 formats come in both

progressive and interlaced versions and, like other modern

digital standards; they support a variety of frame rates

between 24 fps and 30 fps.

 You will learn more about the differences between

progressive display and interlacing later in this lesson.

Standard-definition television

Prior to the invention of high definition, there was only one

standard in the United States, NTSC (National Television

Systems Committee), which includes settings for both 4:3



and 16:9 aspect ratios. While technically it has been

replaced by the ATSC standards, the term NTSC is still

used by most video cameras and editing and graphics

applications when referring to standard-definition,

broadcast-quality video.

NTSC and NTSC widescreen: Graphics applications

designed to produce content for broadcast, such as Adobe

After Effects, Adobe Photoshop, Adobe Illustrator, and

more, include pre-built settings for creating video projects

called presets that correspond with the most commonly

used broadcast standards. The NTSC presets include

settings for both a standard (4:3) and widescreen (16:9)

aspect ratio. They use the same dimensions, 720 × 480, but

different pixel aspect ratios, and this is what accounts for

the difference in shape. Devices that comply with the NTSC

standard use a frame rate of 29.97 frames per second.

PAL

PAL, or Phase Alternating Line, is the standard for

broadcast television used throughout Europe and much of

the rest of the world outside of North America. PAL differs

from NTSC in several key ways, including dimensions and

frame rate. It uses a frame rate of 25 fps, which is closer to

the 24 fps used in film and, like NTSC, it has both a

standard and widescreen setting.

PAL and PAL widescreen: In applications such as After

Effects, the PAL presets include both a standard (4:3) and a

widescreen (16:9) aspect ratio. Much like their NTSC

equivalents, they use the same pixel dimensions, in this

case, 720 × 576, but each have different pixel aspect

ratios.

Web and mobile device video: There is no single

standard for video on the Web or on mobile devices, though

there are only a handful of competing audio/video formats.

QuickTime, Windows Media Video, Flash Video, Silverlight,



and H.264 are the main video formats. The QuickTime

format is controlled by Apple Inc., and for years was the de

facto standard for web-delivered video. The freely available

QuickTime Player is compatible with both Windows and

Mac OS and is used to view QuickTime Movie (.MOV) and

other video file formats. QuickTime format video is also

supported on some mobile devices; most notably the Apple

suite of phones, iPods and iPads.

Windows Media Video, often simply called WMV, is the

Microsoft standard made by the creators of the Windows

operating system. A variation of WMV is used for

Silverlight video, which is widely used by many

professional media organizations, including NBC Sports for

their live Olympics coverage and Netflix for streaming

videos. Windows Media is also a supported format on some

multimedia players and mobile devices, such as Windows

phones.

Flash video is the native video format of the Adobe Flash

platform, and as such, it is used for the distribution of

much of the world’s online video content. While the Flash

player is widely installed on the desktop computers of

Internet users, it is not as common on mobile devices. In

fact, Adobe discontinued development of its mobile Flash

Player and is recommending the use of HTML5 technology

for mobile devices. Even before this, some organizations,

companies, and other online content creators had begun to

move their rich-media content away from Flash and onto

other platforms, such as HTML5. In recent years, the

dominance of flash video has been challenged by the

natively browser-supported HTML5 video formats, h.264,

and OGG Theora. H.264 is a standard for video

compression derived from the MPEG-4 standard, created

and patented by MPEG LA, while OGG Theora is its open

source alternative. Mobile devices such as the Apple iPod,

Sony PSP and Microsoft Zune, and some HTML5-compliant



browsers support variations of H.264, along with many

mobile phones and third-party video playback applications,

such as QuickTime Player, Flash Player, and the VLC Media

Player.

Understanding frame rate and resolution

Video is essentially a series of individual still images that

are displayed very quickly, one after the other. The frame

rate of video is measured by the number of frames

recorded or played back each second, and it is denoted as

fps, an acronym that stands for frames per second.

Different video standards have different frame rates, and

many video standards support a variety of different frame

rates. As a comparison, American television is broadcast at

30 fps, PAL uses 25 fps, and film uses a frame rate of 24

fps.

If you have a background in graphic design, you may be

familiar with the term resolution, which refers to the pixel

density or the number of pixels in a given space. As such, in

North America, resolution is denoted in pixels per inch or

ppi. For example, images created for printing in high-

quality magazines are usually 300 ppi, while images

created for use on a web site usually have a resolution of

72 ppi. When working with video, ppi is not used to address

resolution. When discussing video, the term resolution is

used to refer to the pixel dimensions of an image: the

number of horizontal and vertical pixels that make up the

actual image. When creating graphics for the Web, these

pixel dimensions determine the relative size of content to

the overall video frame size.

 If you need to create graphics in Photoshop, the default

resolution for video graphics is 72 ppi. The same is true

for web graphics.

Understanding transparency



In broadcast video applications, transparency is often referred to as alpha or

opacity.

Graphics that are used in video are created using the RGB

color mode. Each individual pixel is assigned a unique color

value consisting of combinations of red, green, and blue.

Each of these colors is saved to its own color channel.

When colors are combined, the composite (a full color

image) is created. In addition to the color channels of an

image, some formats can also contain an additional channel

that holds information about the areas of an image that are

transparent. This channel is called the alpha channel. If you

also work in Photoshop, you may already be familiar with

alpha channels, although the meaning of an alpha channel

in video is somewhat different. In Photoshop, any saved

selection is called an alpha channel, and you can have up to

99 alpha channels. In After Effects, as in other applications

designed to work with video, the term alpha channel refers

specifically to the transparency of a still image or video file.

Alpha channels use the 256 shades of gray to represent

transparency. When looking at an alpha channel in most

applications, black pixels represent those that are fully

transparent, white pixels are fully opaque, and gray pixels

represent semi-transparent areas. Only some image and

video formats support saving alpha channels along with the

other image information. Commonly used file formats that

can include alpha channels are: Tagged Image File Format

(.tiff ), TARGA (Truevision Advanced Raster Graphics

Adapter, .tga), QuickTime (.mov), and Flash Video (.flv and

.f4v). Alpha channels are automatically created for the

transparent areas of native Photoshop and Illustrator files

when they are imported into After Effects.



 You can create an alpha channel in Photoshop by

creating a selection, saving it as an alpha channel in the

Channels panel, and then saving the file in one of the

image formats that support RGB and Alpha, such as

PSD, TIFF, or PNG.

Congratulations, you have completed this lesson!

Self study

In this lesson, you learned about some of the technical

details that affect decisions you make when creating your

After Effects projects. As new video, image, and audio

formats are developed and support for them is added to

After Effects, you will also want to understand these

emerging standards. Good sources to keep your knowledge

levels up to date include the Adobe web site (adobe.com)

and forums (adobe.com/support/forums). There are also a

wide variety of print and online journals that serve all

facets of the video and design market.

Review

Questions

1 What are the names of the two different standards that

govern video for American broadcast television and

European broadcast television?

2 What are the different frame rates for American

television, European television, and film?

3 What are some of the areas where After Effects is used

professionally?

Answers

1 ATSC (Advanced Television Systems Committee) is the

name of the set of standards that govern American

television and PAL (Phase Alternating Line) is the

standard used in Europe.

http://adobe.com/
http://adobe.com/support/forums


2 American television uses a frame rate of 30 fps,

European television uses a frame rate of 25 fps, and film

uses a frame rate of 24 fps.

3 Television production, film, on-line video, mobile video,

and presentation graphics are all areas where After

Effects is used.



Lesson 2: Understanding

the After Effects Interface

The After Effects interface can seem

daunting to the beginning user. In this

lesson, you will gain an understanding of

the key elements of the interface and how

to work with the various application

panels.

What you’ll learn in this lesson:

• Working with the main panels that are integral to using

After Effects

• Previewing footage files and composition layers

• Customizing and saving panel layouts called workspaces

Starting up

You will work with several files from the ae02lessons folder

in this lesson. Make sure that you have loaded the

aelessons folder onto your hard drive from

www.digitalclassroombooks.com/epub/aftereffectscs6. See

“Loading lesson files” in the Starting up section of this

book.

http://www.digitalclassroombooks.com/epub/aftereffectscs6


Understanding and working with menus

After Effects has nine menus on Windows and 10 on Mac

OS, located at the top of the application window that

combine with various panels to form the interface of the

program. Some of the menu names may be familiar to you

from other applications, while others may be new and

unfamiliar. You’ll start with the File menu to open an

existing After Effects project.

Opening an existing After Effects project

Opening a project in After Effects is much like opening a

file in any other software program. In this exercise, you will

work with an existing After Effects project to help you

understand the organization and structure of the interface,

and you will soon create your own projects.

1 Choose File > Open Project. Navigate to the ae02lessons

folder that you copied to your hard drive and open the file

named lesson02_StartingProject.aep.

This project is composed of several different compositions

that you will use to explore different aspects of the

program interface.

When a project is opened, the application remembers the arrangement of the

interface from the last time it was used and saved.



2 Choose File > Save As and, if necessary, navigate to the

ae02lessons folder on your hard drive. Rename this file

lesson02_StartingProject-working.aep and press

Save.

Do not close this file; you will need it while working

through the exercises in this lesson.

After Effects menus

The Mac OS includes an Application-specific menu, for commands for hiding

and quitting the Application. For Mac OS users, this is also used to access the

After Effects Preferences dialog box. The remaining menus are consistent for

Mac OS and Windows users:

File

As in most other applications, you use the File menu for accessing key features

of the program that deal mostly with creating new files, opening existing files,

and importing or exporting files. In addition to these common commands, you

will also find features for browsing files in Bridge, creating incremental saves

and collecting files for output.

Edit

As in other programs, use the Edit menu to Copy, Cut, Paste, Delete, and

perform other editing tasks with the content of your compositions. When

working in Windows, this is where you can find the Preferences dialog box.

Composition

The Composition menu holds most of the commands you need to create, edit,

and manipulate compositions. Each composition has its own independent

timeline and is the space where all animation occurs. From this menu, you can

create new compositions, adjust or preview comp settings.

Layer

After Effects places each separate media element on its own track, which is

called a layer. You use the Layer menu to create new layers and edit the

properties of existing layers.

Effect

After Effects is basically a motion graphics and compositing program. You use

the Effect menu to apply layer effects in the application. These effects can be

anything from simple color corrections and drop shadows to more advanced

operations, such as chroma keying, particle generation, or explosive

simulations.

Animation

The Animation menu contains commands to accomplish both common

animation tasks, such as adding property keyframes to create animation, and



advanced tasks such as adding Easing to keyframes or Expressions to

properties to automate animation tasks.

View

You use the View menu to control the Composition panel. From the View menu,

you can zoom in and out, open new preview windows, and set the display

properties for your composition.

Window

You use the Window menu to access the commands that control the After

Effects interface. From this menu, you can choose your workspace and open or

close the various panels found in the application interface.

Help

The Help menu gives you access to the help functions of After Effects. In

addition to the standard After Effects Help command, you can also access

specific references for the keyboard shortcuts and animation presets, as well as

have After Effects check for program updates.

After Effects software versions

After Effects project files are not backwards-compatible, and files created in a

newer version of the application cannot be opened using an older version of the

software. When you open an older After Effects project file in a newer version,

you receive a warning message and you have to use the Save As command to

save the file in the newer format. Once a file is converted to the latest file

format, you are not able to return to using an older version of the software for

additional edits. For this reason, if several people are working on an After

Effects project, they all need the same version of the software.

Understanding the After Effects panel system

By default, After Effects uses a docked, panel-based

interface to organize the work area. The entire interface

configuration is called a workspace, and After Effects

includes a variety of pre-built workspaces to accommodate

different working styles and tasks that you may need to

accomplish. You can also set each panel to move or float,

independently.



The default After Effects workspace is named Standard.

After Effects panels

The After Effects interface is divided into panels, where you

will do most of your work. Some panels are for previewing

footage or animation, and others set options for the tools,

while others are for creating animation. All the panels in

After Effects are accessible through the Window menu. To

help you better understand the panels, we’ve divided them

into two groups: Primary panels, which you will use more

frequently, and Secondary panels, which you will use less

often.

Primary panels

Composition

The Composition panel is one of the most important panels

in After Effects. It is the preview window and the main

animation space that you work in when building an After

Effects project. You can build your animated projects in this

panel, and it has features you can use to change how your

composition previews. Perhaps you want to create, show, or

hide guidelines. Or maybe you need to isolate the alpha

channel of your composition so that you can see which

areas are transparent and which are opaque. This can all

be accomplished in the Composition panel. In this exercise,

you will work with the Composition panel to change the



preview resolution of the display and learn how to reveal a

composition’s alpha channel.

A. Rulers Composition. B. Flowchart Selector. C. Selector. D. Composition. E.

Always Preview Toggle. F. Magnification. G. Guide & Grid Options. H. Toggle

Mask & Shape Path Visibility. I. Current Time. J. Take Snapshot. K. Show

Snapshot. L. Show Channel and Color Management Settings. M. Resolution. N.

Region of Interest. O. Toggle Transparency Grid. P. 3D View Pop-up. Q. Select

View Layout. R. Toggle Pixel Aspect Ratio Correction. S. Fast Previews. T.

Timeline. U. Composition Flowchart. V. Reset Exposure. W. Adjust Exposure.

1 With the lesson02_StartingProject-working still open,

look in the Project panel and double-click on the

composition named Viewing Comp Alpha to make it

active. This makes the composition visible in the

Composition panel and also reveals the comp timeline in

the Timeline Panel.

Double-clicking on any composition in the Project panel makes that

composition active in both the Composition and Timeline panels.


